Has anyone been able to get a working NFS 4 automount in Mac OS X?

I'm desperately trying to find a way to automatically mount a NFS v4 share from my NAS to my MacBook Pro with Mac OS 10.11.6, but keep hitting a kernel panic.

Upon boot/login, the automount works perfectly. And I can manually u/mount the share (mount -o nfsvers=4 nas:/nfs/htpc-media /tmp/foobar) without trouble. But when I put my Mac to sleep, I get a kernel panic about 2 seconds after waking it back up.

NFS v3 works a little better, but it will still occasionally crash after a few wakes. I'd really prefer to run v4 services only.

Here's the client setup:

  • /etc/auto_master

    # Automounter master map
    +auto_master            # Use directory service
    /net                    -hosts          -nobrowse,hidefromfinder,nosuid,nfc
    /home                   auto_home       -nobrowse,hidefromfinder
    /Network/Servers        -fstab
    /-                      -static
    /- auto_nfs
  • /etc/auto_nfs

    /nfs/media -fstype=nfs,nfsvers=4,soft,intr nas:/nfs/htpc-media

And on the NAS (running Debian Stretch):

  • /etc/exports

    /nfs/htpc-media *(ro,no_subtree_check,insecure,fsid=1)

Stuff I've tried:

  • turning off firewalls on both ends
  • using IP addresses instead of hostnames (i.e. instead of nas - rules out DNS issues)
  • lots of permutations of client mount options
  • booting Mac OS X into safe mode (rules out kext)
  • poring through Console to see if there's anything interesting or related
  • automounting shares from a completely separate server (rules out server misconfiguration)

Am I missing something obvious? Any help would be appreciated. Happy to post crash logs if that'd be useful.

  • I ran into the same issue today. Similar setup. So far unable to get things working. Noticed that it seems like automount never unmounts the shares, tried changing the timeouts and tried waiting for an hour (which appears to be the default), making sure the laptop did not enter sleep. Also the issue cannot be reproduces with a samva share... seems to be nfsv4 specific.
    – user270374
    Commented Jan 2, 2018 at 21:54

2 Answers 2


I hit this same problem, mounting NFSv4 volumes on a High Sierra (10.13.3) MacBook Pro, from a known-good Solaris server.

I unchecked the "put hard disks to sleep when possible" option in the Energy Saver prefs, and I haven't seen it since.


I can reliably cause a kernel panic with Kerberized NFSv4 on macOS Mojave 10.14.5 (and earlier) with

$ kdestroy
$ mount -o vers=4,sec=krb5p nfs.example.com:/test_volume filer

i.e. by invoking Kerberos authentication without actually having a Kerberos ticket. (Reported on https://feedbackassistant.apple.com/ as FB6119543.)

Update: Apple confirmed this bug and fixed it in macOS 11.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .