14

I'm trying to install HAXM for Android Studio on macOS 10.13. I went to the 'Security & Privacy' panel in order to allow the software to run, but I've run into an issue.

the issue

No matter how many times I press 'Allow', nothing seems to happen. The message and button remain... I've even rebooted. It's still there.

9

This is a new feature in macOS High Sierra that blocks kernel extensions from 3rd-party developers until manually allowed via the Security & Privacy preferences pane. Note this is different from Gatekeeper — this blocks signed kexts until you allow them, and all unsigned kexts are blocked unless System Integrity Protection is disabled. Gatekeeper blocks unsigned apps from running until you allow them. Apple has some further details in TN2459: User-Approved Kernel Extension Loading.

According to reports such as this issue thread for Karabiner, programs that might be intercepting or simulating mouse clicks such as MagicPrefs or VNC could be at fault. If you can temporarily disable those programs, and be in front of the machine rather than connected remotely via Screen Sharing or similar, it will work.

As a more complex workaround, you can disable System Integrity Protection for kexts with csrutil enable --without kext, then reboot to the regular OS and ensure the Android emulator is working, then (optionally but recommended) reboot to Recovery Mode again and re-enable SIP with csrutil enable. This will automatically add all installed signed 3rd-party kexts to the whitelist.

  • 1
    Now that you mention it, Karabiner's probably to blame. Per a suggestion I found elsewhere, I ended up solving the issue by using keyboard shortcuts to select the 'Allow' button. That said, I'll choose your response as the accepted answer due to its comprehensiveness and high probability of addressing the root cause (i.e. Karabiner-like software). – kylemart Nov 15 '17 at 5:11
  • +1 Temporary disable MagicPerfs did the trick – Vinh VO Jun 8 '18 at 2:09
6

I had this issue with both Google Drive and Karabiner elements not being allowed to load. I closed quit Chrome and the Allow button worked.

  • 1
    I don't have Karabiner, but quitting Google Chrome solved it for me. – 2ni Jun 25 '18 at 9:42
  • Thank you! Quitting Chrome made the Allow button work again! – Hybrid Jun 26 '18 at 4:07
  • Chrome was the problem for me as well. No obvious reason why. – Rupert Rawnsley Sep 11 '18 at 10:12
1

Do you use a Wacom Pen, I have the same issue tried it with a mouse and voila it worked

  • Welcome to Ask Different. How does this answer the question? Are you implying that the OP physically pressed the "Allow" button with their finger and not the mouse? – fsb Mar 20 '18 at 4:05
  • @fsb This is a special case of the "simulated mouse clicks" protection noted in the accepted answer. The Wacom software is not considered a "trusted path" mode of entry. It might be more appropriate as a comment/edit to the accepted answer. – user71659 Apr 27 '18 at 16:23
  • If that's the case, this answer should've included that info instead of building upon a different answer (the OP doesn't mention anything about using a Wacom Pen). Otherwise, this answer should be a comment to the accepted answer and not a stand-alone answer. – fsb Apr 27 '18 at 16:26
0

I would expect an Intel product to be signed and therefore authorized by Apple.
But if you are in troubles you can try to open the App in this way:
Right Click then Control+Open.

Hope this works in High Sierra, this trick works on Sierra.

  • This is a different feature controlling the loading of (signed) kexts, not apps. Introduced in High Sierra. – kirb Nov 15 '17 at 4:14
0

Had this same issue - thought it was because of the trackpad somehow not being recognised as a mouse and nothing. Updated keyboard shortcuts and was unable to 'tab' past the hard break in the option field. after about 30 google searches and a whole bunch of trial and error... the answer in the end was simple.

hold option and click.

(WTF-have no idea why it was so hard)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .