6

Trying to install VirtualBox 5.2 on a Mac running OSX 10.13. The installation fails with an installer message reading "The installation failed."

I've tried the 2 solutions I've been able to find and neither have worked.

I tried clicking "allow" in the "Security & Privacy" preference panel where the download gets blocked. Each time, I ejected the image before trying again with no luck.

I also tried entering sudo spctl --master-disable in the terminal before trying again, but still no luck.

After the failure, the application icon does still appear in the downloads folder, but I'm supposing this isn't a good installation and I'll run into problems using it? Thoughts?

  • If you run spctl —status still shows assessments enabled then you haven’t prepared the system to be modified by Virtual box. Can you confirm you disabled SIP? You can’t disable SIP from the running system, so that would be a clear next step for you. The other point of confusion is if you are locally logged in to the Mac - Emil’s answer covers that roadblock. – bmike May 6 '18 at 14:52
5

I had these same issues installing VirtualBox 5.2 on an employees Mac running 10.13, via remote desktop. After trying all the things you've mentioned I kept googling, eventually finding this thread saying it's a screensharing issue.

There is a report that you cannot allow kext if you are using Screen Sharing.

I use magic perf to intercept various touchpad actions. [...] If you have this problem try to disable any apps that my capture and forward clicks.

Apple are disabling the "Allow" button if it's pressed by anyone BUT the Mac touchpad, directly.

So, if you're also attempting this via some sort of indirect method, or are using something like Magic Perf or Steermouse, disable those and make sure the click on "Allow" is as direct as possible.

Hope this helps someone out there.

  • 1
    The indirect method also applies to bluetooth mouse. Allowing the install via Privacy and Security with a bluetooth (or other peripheral) won't enable the install. It must be clicked on and enabled using the trackpad. I did the enabling and install with the trackpad and it worked for me. – SKDon May 6 '18 at 13:59
5

This worked for me on High Sierra 10.13.4:

  • System Preferences > Keyboard > Shortcuts > Select 'All Controls'

enter image description here

Then:

  • System Preferences > Privacy & Security > Press 'Tab' until 'Allow' is selected > Press 'Spacebar'

Note: the Privacy & Security page may need to be unlocked before 'Tab' will work.

Hope this helps!

Credit to @dansanduleac's answer on GitHub

  • This solution also worked with VirtualBox 6.0. – Mark Jan 31 at 0:52
3

Worked for me on 10.13.4

open script editor and run the following command, replacing x and y as necessary.

tell application "System Events" to click at {x, y}

get your x,y values by cmd + shift + 4 to bring up the screenshot tool. hover over the allow button and put those values for x and y respectively. make sure the allow button is visible when you run the script.

1

This works for Virtualbox 6.0 on macOS Mojave (10.14.5), but should also work for other versions:

  1. Uninstall Virtualbox (assuming it didn't install properly)

  2. Boot into recovery mode (restart your mac while holding the Command and R keys)

  3. Once booted into recovery mode, click Utilities->Terminal in your top bar

  4. Run these commands:

    spctl kext-consent disable
    spctl kext-consent add VB5E2TV963
    spctl kext-consent enable 
    reboot
    

    (VB5E2TV963 is the Oracle developer id, it shows up during installation at top right of installer if your click the lock icon. kext-consent add may work, but maybe not :D)

  5. Install virtual box again
  • this is the only solution that worked for me. Have no idea why it happened. Have 2 Macs, only one had the issue ... – Mircea Stanciu May 22 at 6:15

You must log in to answer this question.

protected by Community May 16 at 10:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .