4

I try to establish a serial connection with my MacBook (High Sierra 10.13.1) and need help.

I have a Belkin F5U103V USB-to-serial adapter and want to connect to a HP ProCurve switch. I tried to follow several instructions such as this one or the installation instructions in the ZIP-archive of this driver but none of this worked.

After the installation of the mentioned driver of my device, all of the instructions I found asked me to use the ls /dev/tty.*, ls /dev/*usb* or the ls /dev/cu.* command to find out the device which is associated with the usb port. This is the step wich fails for me.

The ls /dev/*usb* command does not return a result at all. The two other commands return

/dev/cu.Bluetooth-Incoming-Port

/dev/cu.SOC

/dev/cu.MALS

/dev/cu.iPhonevonFirstnameLastname-Wire

(and the same name with tty. instead of cu. respectively), which means, that I am not able to find a serial device which is associated with the usb port.

After the installation of the driver I had a "USB serial controller" in my network settings. When I change the modem to a "Null modem", set the baud to 9600 and try to connect, a popup appears that says that my device is not available.

enter image description here

Strangely, when I try to connect to the switch via Serial App, I can see the USB serial port and it works perfectly to connect to the switch which means that the USB-to-serial device works fine generally.

enter image description here

I want to open the serial port with the build in screen command preferably (screen <device> <baud>). What is the reason why I cannot find the device as mentioned in the instructions and how can I use the build-in tools to open a serial connection without 3rd party software?

If it is relevant, I have a MacBook Pro 2016 which means that I have USB-to-serial adapter which is plugged in into a USB-c-to-USB adapter.

  • Strangely, the Serial App even works after the un-installation of the mentioned driver. I wonder which device is used by this app. – Drudge Nov 13 '17 at 17:28
  • Try ls /dev/cu* (no period). Also, see this relevant answer – Allan Nov 13 '17 at 18:06
1

You need a specific driver for the USB-Serial device. MacOS support for these - especially in recent versions of the OS - is spotty, at best. You need to check even ones that claim MacOS support because their support might have worked up until about 10.6, when Apple started getting serious about kernel and driver security, sandboxing, etc.

FWIW, USB-Serial devices based on the Prolific chipset seem to have most luck.

Serial.app works because it uses its own driver, not the /dev device. For most uses, I'd say this app is required if you want to maintain sanity.

1

A late entry to this question, but hopefully this will help someone:

For serial comms using a late-model Mac, my experience is that there are two things you should know:

  1. Tripp-Lite USB-C-to-DB9 cable

  2. Jeroen's USB Serial Driver

These are not intended as "commercial endorsements"; I have absolutely no financial stake in either. They're simply tools that allowed me to get where I needed to be, and ended hours of failure and frustration. Everything else I tried was half-baked and not-ready-for-prime-time: Unsigned drivers, drivers that occasionally worked, drivers provided on mini-CD hard media (?! - didn't even know they made these any longer until I bought the Tripp-Lite cable), interface cables that "just didn't work", etc, etc, etc. If you're interested, there are a few more details posted on my GitHub page.

And as far as CoolTerm goes: I used this program for years, and really liked it. Unfortunately, running it now (HighSierra 10.13.6) generates "warnings" that it's not optimized for Mac. I don't know if there's a 64-bit version coming or not.

Hope that helps.

0

I've been using CoolTerm since 2014 to serial talk with the barometer chip hooked up to my Arduino. Straight USB, no USB to serial cord needed. Pretty easy to set up, and plays nice with AppleScript. Free, so you've little to lose trying it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .