4

Following situation. I am using the "iSafeBox" Password Safe on my iPhone 6s where I keep all of my account and password details. After upgrading to ios11 however, I found that the app is not compatible and that the developer will not continue development. To make things worse, I also cannot go back to iOS 10 as it is not signed anymore...

I have an old iPhone 6 running iOS 10.3 and was hoping I could restore that one with the backup of the 6S, but iTunes tells me that the version is too old and cannot be restored with the iOS 11 backup.

When checking the backup of the iPhone 6S running iOS 11, I found that the unsupported app was still there and got transferred over into my itunes library. I am now wondering if there is any way I can extract that specific app + data, and load it onto my iPhone 6 running iOS 10.3, then continue using it there?

I am open to jailbreak and all sorts of shady stuff as long as I get back access to my passwords T_T

Thank you!

  • Please report your problem to Apple support since this is a consequence of their policy to block any iOS version rollback, even in case of failure or loss of information. [return] Your total loss of data is a consequence of an Apple software upgrade. [return] Don't let them try to convince you are alone in this case. – dan Dec 4 '17 at 12:44
  • 2
    Appreciate the comment. I ultimately solved the issue by using the phone explorer software on my phone, extract the app data, and then use another iPhone on ios10 and replace the app data of the same app there. Not elegant but did the trick, all without jailbreak. – Armitage2k Dec 4 '17 at 12:47
  • Please, make an answer of your useful comment. It is a trick that may help others with an old iPhone available. – dan Dec 5 '17 at 11:40
  • Could you please tell me more specifically how you managed, as I'm facing the same problem? How did you install the app, it' not even on AppStore... :/ Thanks! – Confused Dec 22 '17 at 15:27
2

That’s how I solved it:

Requirements

  • iPhone / iPad with iOS 11 running the password app which is not supported anymore
  • spare iPhone / iPad running iOS 10 with same password app freshly installed and no data inside

Procedure

  • download the latest free trial version of the iPhone Explorer
  • connect the iOS 11 device
  • go to Apps
  • select the password app
  • click MOUNT APP to display the appdata folder in a virtual drive with limited read / write access (Note: the trial version of iPhone explorer offers only 150MB of data to be written)
  • copy all files and folders to your local hard drive, make sure the folder structure is the same
  • connect the iOS 10 device
  • go to apps
  • select the empty password app
  • click MOUNT APP and copy over the iOS 11 appdata from your hard drive to the iOS 10 device
  • disconnect the iOS 10 device
  • open the password app and enter your master pin
  • you should now see your passwords listed as usual

Hope that helps!

You must log in to answer this question.

protected by bmike Dec 22 '17 at 15:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .