1

I need to print a web page for a person with bad eyesight. I don't want to change my Safari font settings, as I can see web pages just fine. I only want to print the web page in a larger size.

I have upscaled the font size in the print settings to a larger percentage, say 150% for example - however, the result cuts off the edges into different printed pages, rather than actually scaling the text and fitting it to the pages properly.

For example, this web text appears in the normally scaled print size as: enter image description here

However, when scaled to 150%, page 1 of the print preview shows:

enter image description here

And, page 2 of the print preview shows:

enter image description here

You can see how the text is cut off on the right side and moved to the next page.

What I want is the text to be enlarged and scaled so that even if only a few words fit on a line, say, the print will still flow downwards appropriately:

"Cabbage leaves are stuffed with ground beef,
rice, then simmered in tomato soup. Works
great in the oven or a slow cooker. Serve with
...

-the image might flow down to here-

and so on...

  • 1
    And, if anyone is curious, the web page I'm currently trying to print is Golabki (Stuffed Cabbage Rolls) - Printer Friendly - Allrecipes.com – leanne Nov 12 '17 at 17:06
  • Turn the paper landscape for a quick fix, but I usually drag recipes out in sections & rebuild in Pages, to give them a coherent look in my binder. – Tetsujin Nov 12 '17 at 17:17
  • Tried that, @Tetsujin. The text is no larger; it's just spread more across the page. – leanne Nov 12 '17 at 17:19
  • I'd go for Pages then. Finer control & you can save a template to use next time. – Tetsujin Nov 12 '17 at 17:25
  • Perhaps a custom CSS stylesheet file for formatting print layouts would work but that is quite advanced for the average user. – bjbk Nov 12 '17 at 18:03
0

Easiest & fastest way to do it is to temporarily change preferences for minimal font-size.

  1. open in Safari's Application Menu: Safari / Preferences or use hotkey +,
  2. there tab Advanced
  3. there turn on checkbox "Never use font size smaller then XX" where XX is your preferred font-size. That is it.
  4. print it

Safari's preferences : advanced (part)


So the next screenshot demonstrates the result. On the left side not changed min-font-size (opened in Preview.app as prepare/preview before printing). On the right side - all is same but min-font-size is 24.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .