1

It wasn't like this before. Somehow, if I leave my USB plugged in, my Mac doesn't boot. Instead it gets stuck at the Apple logo with a very slow progress bar. When the bar finishes, it just waits. I tried resetting the PRAM but nothing changed. I also tried booting into Safe Mode, but it wouldn't boot. I did boot into Recovery Mode (cmd + r), and was able to repair the disk, but it said everything was fine. But I still can't boot my Mac. What should i do?

PS: I dont know why, but there is a Disk named Mac OS X Base System in Recovery Disk Utility, which I only see when I can't boot my Mac. I also can't eject this.

  • Can you boot off single user mode that holding cmd+S at start-up chime and do you have a backup of your data? – user244378 Nov 12 '17 at 15:02
  • Yes i can boot into single user mode, how can i backup mu data? Actually i dont need everything, if i could take my photo archive and music it will be ok i can build everything else :( [Edit: Also, i have bootcamp partition which works perfectly.. I dont know it could help me about that but wanted to say]. [OMG I CAN ACCESS ALL OF MY MAC DATA FROM BOOTCAMP?? IS IT NORMAL...] – oguzhanvarsak Nov 12 '17 at 15:03
  • Yes you can from boot camp just boot to Windows and you know where you can see your c drive and disks you can access your Macintosh HD partition and then you can copy your stuff if this doesn't work then comment. – user244378 Nov 12 '17 at 15:49
  • @Geek yes i already copied my important stuff. So, the only solution for bootloop is reinstall macos for now? – oguzhanvarsak Nov 12 '17 at 15:50
  • Yes you have to reinstall macOs.Or just perform a clean install by erasing the drive Nd then reinstall the macOS – user244378 Nov 12 '17 at 15:51

You must log in to answer this question.

Browse other questions tagged .