1

My iPad ran out of battery, was on charging whole night but still showing the “need charging icon” when I plug in.. Sometimes (I don't know whats trigger it) it displays charging icon, charges for 5 min, boot up with 2% then it shuts down and then does the same thing again. Last time I tired pressing home and lock button to keep alive the charging icon about 50 mins, boot up and the same thing happened again. I tried DFU, recovery and many more but can't enter.. Any recent method? Tried this: https://discussions.apple.com/message/25454333#25454333

Usual behaviour:

  1. Need charging icon while plugged in charging.
  2. After a while "Need charging icon" changes to "Charging icon"
  3. It starts booing, shuts down and display "Need charging icon"

And it's going on for a long time, I don't think the iPad could handle it if it really wasn’t charging...

  • Does it work if you use it plugged in? Have you tried a different charger? How old is the iPad? – Tetsujin Nov 12 '17 at 11:50
  • In addition to what Tetsujin asked, have you tried a different cable as well? – Monomeeth Nov 12 '17 at 12:23
  • Yes, I tried all the obvious things(dust, cable, adapter, etc...)No, I can't use it. – csabigabi Nov 12 '17 at 14:25
  • Forgive me if the question seems stupid, but did you try connecting the charger to a different power socket? It happened to me in a hotel, I thought the socket was always on and instead it switched off every time I went out of the room.... Also, sometimes even in the home a socket can be switched off with a switch or can go off because of a safety switch... – Gio Valerio Nov 12 '17 at 15:04
  • @GioValerio Yes, thank you but the socket is working well. – csabigabi Nov 12 '17 at 15:21
0

Because you have already tries the classic things, I would suggest that you either:

  • have a damaged charge port
  • have a dead or dying battery
  • have damaged the charge circuit on the logic board.

Take a magnifying glass and inspect the inside of the charge port and look for and damaged pins/contacts. To test the battery, use a battery utility, such as [http://www.coconut-flavour.com/coconutbattery/|coconutBattery] (for Mac) or [http://www.3u.com/|3uTools] (for Windows). It will tell you what the health of the battery is. Anything less than 70% of design capacity will require replacement. Finally, if you have been using non-original charging bricks (especially cheapo car chargers), you may have damaged the charge circuit on the logic board. This can be repaired but requires micro-soldering.

  • Went to one of the trusted 3rd party services and yes it needs to replace the powermanagement IC on the logic board. The interesting thing is that I only use original accessories. – csabigabi Nov 22 '17 at 18:58
1

Sometimes lint or dust end up in the charging port of the ipad and the charging cables don't make contact properly (happened to me just one week after buying my iPad Pro and I was panicking). Try gently cleaning the port with a dry air pump or just a microfiber cloth, or even a toothpick.

  • 1
    An air duster should work too. – Matthew N Nov 12 '17 at 14:54
0

Try shutting down your ipad using the sleep button, that worked for me once.

0

I agree with @Minho. the first thing I'd try with these symptoms, is to try a NEW or different Apple cable on a different power cube. There are chips inside the cables themselves that can go bad, or stop working when they heat up. So, the cables can go bad, but still look brand new.

If it's not the cable. Since there is not enough power to boot the phone, it's in charge-only mode. It will stay there until at least 5% charged, or there-abouts. So, if there is a misbehaving app that's depleting the battery as fast or faster than the device can charge, it's not going to get out of it until we can get that app killed. I've been in this loop before, it's difficult to get out. I'm not sure if your device has actually gotten charged up enough to boot up completely, but if it ever gets to the home screen, I'd reboot it immediately, Home + Sleep button for over 5 Seconds.

You have mentioned DFU, so I'd send you to the Apple store. They can help you, but I can't say if it will be free or not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .