10

I have nsurlsessiond eating all my bandwidth. That's because I have iCloud Drive enabled. But I wouldn't like to deactivate it for good, 'cause when I'm at home, where I have a fiber broadband, I like it to keep iCloud content in sync with my local drive. However, when I'm traveling I like to be able to stop this guy from eating all my paid LTE mobile service. I tried to uncheck iCloud but it pops-up a message saying that all my iCloud documents will be deleted from my local drive. If I press the button to keep a copy, it sais it need to finish synchronization before stoping the service.

I tried links like the one below, which recommends stopping the nsurlsessiond process, but it keeps coming back.

How to know what nsurlsessiond is downloading

Is there a way to just pause iCloud drive or to make it work only when I'm at home?

Thank you

1
  • What's really odd about this is that (in Catalina at least) when you hit the "pie chart" icon next to "iCloud Drive" in the Finder, it brings up a 'downloading' dialog with a cancel button. However, for me at least, that cancel button does nothing. It doesn't even highlight when I click on it.
    – Calion
    Sep 21 '20 at 16:39
4

I'm not sure how it exactly accomplishes it, but take a look at TripMode. It offers the functionality you're looking for, and even automatically switches based on the network you're on.

3
  • Thank you for the tip, it seems promising. But before going to a third party solution I tried using macOS internal firewall. There is an option which blocks, or at least should, all incoming connections. After I enabled it, It says: The firewall will block all sharing services, such as file sharing, screen sharing, bonjour messages and iTunes Music sharing. If you want to allow sharing services uncheck the option "Block all incoming connections". Shouldn't iCloud Drive be within this category?
    – felima
    Nov 13 '17 at 2:35
  • @felima Don't think so, but I don't know. In any case though, that seems like a bit of a brute force solution.
    – JMY1000
    Nov 13 '17 at 4:28
  • Indeed it may be seen that way, but would work as expected with just one checkmark option with no need for 3rd party software. According to apple's firewall documentation OS X: About the application firewall The system services that are still allowed to receive incoming connections are: configd, which implements DHCP and other network configuration services mDNSResponder, which implements Bonjour racoon, which implements IPSec As per my understanding iCloud Drive should be blocked, weird.
    – felima
    Nov 13 '17 at 5:19
4

I am using this trick to temporarily disable or enable Desktop and Documents synchronization (Tested on macOS Sierra 10.12.6)

  • Enable Firewall if it is not enabled.
    System Preferences > Security & Privacy > Firewall
  • Add Finder to the firewall list
    Press the plus button and search for Finder app.
  • Select "Block Incoming Connections".
  • When you are ready to re-enable the synchronization just select "Allow incoming connections".

This method is acceptable for me because I just need to enable the synchronization time to time
(I do not own any other Apple device thus I use iCloud synchronization like an online backup).

Note that when Finder is blocked you will stop synchronization FROM your Mac to iCloud. However, changes made in the cloud will be synchronized to your Mac (Eg. using the iCloud web interface or other device).

enter image description here

3
  • Didn't help. I added Finder.app and set "Block incoming connections" but iCloud sync continued to upload files (even after restart)
    – Dima L.
    Sep 10 '20 at 10:11
  • This is an old answer. What is your version of macOS? I will check if there is something different
    – ePi272314
    Sep 11 '20 at 11:10
  • MacOS Catalina 10.15.6 - the solution doesn't help.
    – Dima L.
    Sep 20 '20 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .