1

Today is the America’s Veterans Day and, in the Activity App of my iPhone, there's the relative  Watch's badge.

I just did my one hour running (recorded by Runtastic and the Activity app on the  Watch) so I generously reached the 11 minutes target to get the badge but, despite this, I didn't received the badge. Am I the only one?

P.S.: I'm not American so, to display the badge on app, I changed the zone on my  Watch to USA. I did it for every US only badge and it always worked, so it shouldn't be the problem...

2 Answers 2

1

Thanks to this discussion https://www.reddit.com/r/AppleWatch/comments/7c9g3b/did_you_get_yours/?st=j9vre0ac&sh=5dd7c06a I solved.

Just reboot the iPhone, then the Watch and you'll get the badge!

enter image description here

1
  • I’m not going to down vote this but a reboot isn’t working for the 2018 badge. Curious if this is a server side issue.
    – bmike
    Commented Nov 12, 2018 at 2:40
0

The badges seem all caught up for 2018 by the 15th.


The 2018 badge was failing a lot of people who reside in the US using us address / iCloud and App Store and localization. This failure to award the badge was temporary (48 to 72 hours at most)

I contacted Apple support and it can take up to 9 days for specia badges to get issued. If the servers don’t fix things at that point, you should contact support.

enter image description here

The important thing is to get your workout(s) in and then check back for the badge later.

In my case, both of the workouts above were more than 20 minutes and I tried the reboot trick to no avail. It’s clear from multiple failures it’s not us not meeting the goals for this badge and more that the badge issuance can be delayed and not be instant.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .