6

My default browser is currently Firefox. On those rare times when I do open Safari, it displays a message at the top of the Favorites page asking if I want to make Safari my default browser. How do I make this go away?

Edit 1: I am using High Sierra.

3
  • What version of macOS are you on? I'm on High Sierra and it seems to act differently than yours Nov 10, 2017 at 15:40
  • If you want Safari, set it as default browser
    – LexS
    Nov 10, 2017 at 16:17
  • 3
    LexS — I don't want Safari Nov 14, 2017 at 18:53

2 Answers 2

1

Safari stops asking when it detects it has once been set as the default web browser, so the trick is to set it as the default browser and then switch back the default browser to Firefox.

  1. Go to System Preferences > General
  2. Set the Default web browser to Safari
  3. Quit System Preferences
  4. Open System Preferences > General
  5. Set the Default web browser to Firefox (or any other browser)

Safari will no longer ask to be the default browser until the next major macOS upgrade.

2
  • Confirmed working as of macOS Catalina 10.15.6.
    – knite
    Sep 30, 2020 at 18:40
  • I spoke too soon, the popup returned a few days later!
    – knite
    Oct 14, 2020 at 18:34
1

Without knowledge of your macOS version:

  1. Open System settings
  2. Choose General
  3. Choose from the pop-up menu in the default-Browser section your preferred browser.
1
  • 4
    My default browser shows up as Firefox there. Basically my problem is I want to stop Safari from nagging me about changing my browser when that isn't something I want to do. Nov 19, 2017 at 1:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .