5

I am using macOS 10.13.1 and Safari 11.0.1, since I upgraded from 10.12 it's not possible to access https websites through IP address.

For example: I want access the config GUI from a router

  1. I open Safari go to https://​192.168.0.1.
  2. Safari says: "connection is not private"
  3. I click "Details" → "Open website" → "Visit website" then I have to enter the password from my local user.
  4. The site reloads and again I can see the message: "connection is not private".

If I create a hostname entry in /etc/hosts like: 192.168.0.1 my.funny.router and go to Safari and open https://​my.funny.router the connection can be established after I clicked "Details" → "Open website".

Is there a workaround? Can I disable that "feature"?

  • I guess this problem was fixed by Apple. Because now after enter pw from my user I can access the site through its IP. – fips123 Mar 5 at 16:17
1

The bypass can't be bypassed apparently. Note also that it may fail and keep requesting authentication if your hosts file entry has both short and FQDN specified. In that case you MUST use the FQDN. This is possibly because the Mac will append your local domain to any unqualified host names before checking for permission and (I am guessing) that a remote site identifying as your local machine domain (mymac.local for example) can't be added to the keychain. OR it might be that having ONLY a short host name in /etc/hosts would be OK but if you have BOTH long and short names specified then you must use the FQDN as that is the one that resolves in your host file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .