3

This is driving me crazy! Whenever I reboot in OSX High Sierra all the applications I had open automatically reboot. In Login Items NONE of these applications are there!

How do I stop this from happening?

3

It's a standard feature & has been there for years.

It asks you as you shut down or reboot - just uncheck the box, it should remember.

enter image description here

-1

Apart from the checkbox mentioned in Tetsujin's answer make sure you don't have any unwanted startup items under

Apple menu > System Preferences > Users & Groups > Login Items.

Make sure you select the unwanted auto-start item and click the - button since Hide will only hide the app from the Dock.

Also, if you reboot by typing sudo reboot from terminal, then apparently the setting for reopen windows is assumed to be true. In such cases, to avoid auto-starting the apps, after you have entered your password on the login screen, press the SHIFT key, then ENTER, and then keep holding the SHIFT key until the Dock is shown.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .