8

For last 2 days I am not able to login to my MacBook Pro. It was working fine and suddenly for no reason after I last shutdown my mac I am not able to login. The mac starts up fine and goes to the login screen. After I enter my password the progress bar is stuck in 70%-80% and sometimes at 100%.

I tried resetting NVRAM and SCM but it didn't help. I also tried following the steps mentioned in Justin Silver’s blog post but it also didn't help.

As mentioned in the post, I moved all the 3rd Party items from /Volumes/Macintosh\ HD/Library/Extensions to /Volumes/Macintosh\ HD/Library/ExtensionsDisabled. Since I was not able to find any *.kext in /System/Library/Extensions older than 2016, I didn't moved any *.kext from /System/Library/Extensions location.

My MBP is mid 2012 and have the latest OS X, also I have 1TB HDD and 8GB RAM.

I am not able to login using SafeMode as FileVault is enabled. I even tried login in Single User or Verbose mode but I am not able to do so.

Can anyone help me to fix this.

5

I found a solution for this problem by robertk1 and he writes the following:

I would enter my password correctly and then the cursor would change to the spinning pinwheel and just sit there forever. The only way out was a power off reboot.

This is exactly what happend with my machine and it looks like it's same with yours. I hope this also works with FileVault enabled. There are two ways to solve this. With and without a guest account.

In case you do have access to the guest account follow these steps by hijoncon:

  1. Login as guest
  2. Open Terminal (cmd + space then search terminal)
  3. Enter su your_account
  4. Enter your password
  5. sudo find /private/var/folders | grep com.apple.LaunchServices | grep csstore
  6. Remove every .csstore your find like this sudo rm /private/var/folders/cd/someLongRandomNameHere/someFolderNumberHere/com.apple.LaunchService-whatever.csstore

If you don't have access to the guest account you can try different ways to get into the machine (like SSH) robertk1 suggests:

To do this, you'll either need to be in a recovery console, or ssh into the machine, or boot from an external drive, or otherwise somehow get to a command prompt.

Once you are in the machine you can delete the files like described above in the last steps.

  • Holy smokes I can't even express how much gold this information is! I spent a lot of time rotating between reboots, safe-boots, hard resets, "soft" resets by triggering the reboot dialog... and this thing solved it in 2 minutes. :O – Andrea Lazzarotto May 23 at 15:34
2

I know this might not be an option for you is not really a solution... But what I did is to reinstall the OS by entering into Recovery Mode with Command + R right after pressing the power button, same as you would do with safe mode.

I didn't lose my files by doing so, but it took 3 hours more or less for the installation to be completed. Let me know if you found another way.

  • i did the same, but the problem still occured T_T) – Kokizzu Apr 10 '18 at 14:35
1

Try this:

Fill the password as usual, but don't hit enter yet. Hold the options button and then click the login arrow button.

I've been stuck for a while now, finally this solved, a method in which I introduced the options button. Hope this helps.

  • Don't hit the return key!! HIT THE ARROW KEY ON THE RIGHT SIDE TO LOGIN AFTER FILLING PASSWORD. The second time I restarted, the same issue. The thing is, I was using the return key to commit the password but here it seems if you hit the arrow key on the right, logs in just fine. – Hapot Jun 21 '18 at 18:59
0

You can still log into Safe Mode, even with File Vault enabled, and that’s exactly what I’d try next if I was you.

The only difference is that you’ll probably be asked to log in twice: once to unlock the startup disk, and again to log in to the Finder.

Full instructions below:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: Since you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. can you login okay?)
  6. Exit Safe Mode by restarting your Mac as normal and see if you can login now
  • I tried that but it didn't asked me to enter the password twice and after I enter my password 1st time it goes till 100% and stays there. – Ajitav Dutta Nov 9 '17 at 8:26
  • Ok, so how long have you waited after the 100% ? It’s not uncommon for Safe mode to take 10+ minutes in some case, and about six months ago I came across a user who had to wait over 30 mins. – Monomeeth Nov 9 '17 at 8:34
  • I tried that yesterday night and left it as it is and till morning it was stuck in 100%. Now, i just followed the instructions that you have given and waited for 20 mins still it was on 100%. – Ajitav Dutta Nov 9 '17 at 8:36

You must log in to answer this question.

protected by bmike May 25 at 13:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .