4

I switched from an older MacBook Pro to a newer unit. It runs macOS High Sierra V10.13. All files were migrated using the Migration Assistance app. Within one night all files and software were transferred. Now everything is fine, except for files - every file I double-click to open states "file-abc.zip" is corrupted and can not be opened. It's recommended to put this file into trash.

This happens on every single file there is. All kind of formats (zip, jpeg, xlsx,....). Every time I get the same error message.

However, I can just open the files if I open the software first (let's say MS Excel) and select "Open file" from context menu and select a file. Now it will open just as it should. If I double-click the file in Finder will result in this error message.

Whats wrong here? It seems the files are all fine, just my MBP is a bit confused? How can I get this straight?

Bonus info: If I download files from web (Firefox/Chrome) the files are corrupted as well. If I create the file myself (with a software by saving it to disk) it can be opened with double click.

/update:

Some more strange behavior I found on this macbook. In settings "security" I can change the 'allow applications downloaded from' to "verified sources" ('anywhere' is not available at all) but when I jump back to main settings and again to this security it is changed back to "App Store". It doesn't saves my setting!

  • The first thing I would try is booting into Safe Mode and see if the problem persists. I think your files are safe, it's just the setting associating the file with the program is somehow corrupted. – Allan Nov 8 '17 at 14:21
  • I booted my mbp holding "shift" (safe boot mode), however the same problem appeared. Also I changed the default software that is associated with this file type, however it didn't help. – michaelsinner Nov 8 '17 at 20:06
2

I found the solution to this error (btw. the error message is "____ file is damaged and can't be opened. You should put it to trashbin."):

The gatekeeper function on Sierra is a bit altered and the last option "From any source" is not available for security settings. So I had to run this command in terminal:

sudo spctl --master-disable

Now the option "from any source" is available for gatekeeper. After I selected this option the files became available again.

  • Thank you. I had the same issue and your fix worked. Really appreciate it. – lolohbk Jan 8 '18 at 5:16
  • Dealing with this myself. I don't like the solution though - having to disable Gatekeeper completely to open my own files is a bit ridiculous, especially as OS X apparently re-enables it after 30 days. But it's buggy as heck. Before disabling it, the "Allow files from signed developers" setting was not respected. – dr.nixon Mar 21 '18 at 3:58
-1

I had a similar problem. Apple had me re-install High Sierra, which fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .