4

For a while now I've been importing mp3s, setting them as "Audiobook" and listening to them via iBooks, like normal. However, for some unknown reason a few weeks ago, this stopped happening: Even though they show up in "Audiobooks" on iTunes, they WILL NOT show up in iBooks anymore—they still appear in the Music app, like a regular mp3. Nothing I have tried will force it to show up in iBooks again.

Edit, to clarify: The problem is that I add an MP3 audiobook to my iPhone via iTunes in the normal matter, but it shows up in "Music" and NOT "iBooks" EVEN THOUGH I set the file type as "Audiobook." iTunes—on multiple computers!—correctly shows the audiobook, but not on the phone. Furthermore, I deleted an old audiobook on the phone yet iBooks STILL shows it!

This is on iOS 10.3.3, iTunes 12.7.1.14, and reconfirmed on iOS 11.2.2, iTunes 12.7.2.58.

3 Answers 3

3

If I am understanding you correctly, you have MP3s which are audiobooks which exist in iTunes on a desktop/laptop and you want them to sync to a mobile device and be automatically available in iBooks the way they used to be, is that right?

Apple recently changed the way audiobooks sync between iBooks and iTunes. This support document lets you know how you can sync these files using iCloud which seems to be the way they are encouraging people to do this sort of thing now. In short

  • iBooks must be turned on in iCloud settings on your Mac and your device
  • in iBook's general preferences you have to makes sure "Sync bookmarks, highlights and collections across devices" is checked
  • Make sure you don't have "Hide iCloud Books" selected from within whatever Collection you are viewing in iBooks

And then when you sync you should see these files as "downloadable from the cloud" (i.e. with the little cloud icon next to them) and then you can tap to download.

I think this is sort of a nutty workaround for what used to just work but seems to be how Apple is trying to get people to do what you are tying to do here.

4
  • 1
    Hm. Strange. I started following these instructions and turned on iCloud Drive—I don't think I had to change anything else. Now my audiobook does show up in iBooks, even though iTunes already showed it ON MY DEVICE already! Really strange and stupid... but thank you!!
    – T3db0t
    Commented Nov 8, 2017 at 21:01
  • I'm unchecking this answer and re-opening the question. The problem is that I add an MP3 audiobook to my iPhone via iTunes in the normal matter, but it shows up in "Music" and NOT "iBooks" EVEN THOUGH I set the file type as "Audiobook." iTunes—on multiple computers!—correctly shows the audiobook, but not on the phone. Furthermore, I deleted an old audiobook on the phone yet iBooks STILL shows it!
    – T3db0t
    Commented Jan 9, 2018 at 17:15
  • In other words, this doesn't seem to have anything to do with iCloud.
    – T3db0t
    Commented Jan 9, 2018 at 17:17
  • Aww too bad, I really thought we had it. Commented Jan 10, 2018 at 18:26
3

I realize this is an older question but just had the same issue myself and figured out how to solve it. This was the first thread that showed in Google when looking for the answer. So for anyone who happens across this issue here is what you do.

If you are trying to sync an audiobook from your computer to your iPhone you no longer use the "iTunes" app, now known simply as "Music". Instead, you have to open the "Books" app and go through the same process. From Books you can select "File, Add to library" and upload the files the same way you would have in iTunes. After that, return to the iPhone sync settings and the audiobook should be listed for you to sync. You can add the files to the "Music" app and have all the same settings checked but for some reason they never show up in sync. The key is to add them through Books.

1
  • Thanks for this, completely answered my question..... what a bad UI for this process, but I'm glad it works. Sookie Stackhouse books on my wife's old iphone ftw! Commented Feb 16, 2021 at 21:13
2

There's a workaround for this. Once mp3's are added to your iTunes library & marked as audiobooks (through the "media kind" option via /right click/ -> "Get Info" [multiple files selected] or "Song Info" [single file selected]), you can sync audiobooks manually as follows:

  1. plug your iPhone into your Mac

  2. access the device through iTunes on your Mac

  3. click on the Audiobooks tab under Settings, on the left-hand panel under the device name

  4. in the resulting right-hand window, you should see the audiobook title, with an empty checkbox next to it

  5. above that, at the top of the window, there will be an option to Sync Audiobooks, with two options underneath: All audiobooks & Selected audiobooks. Check whichever you want.

  6. Re-sync your iPhone

The audiobook should now turn up in your iBooks app under Audiobooks, same as before. I hope this solves your problem!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .