6

I'm running High Sierra 10.13 on a Macbook Pro Touchbar 2017 with British keyboard.

When at the desk I use a Corsair K70 mechanical keyboard set as British Mac layout. I don't look at the keys to type and prefer mac layout so no problem.

Seemingly randomly though, my `/~ key which is usually left of z started producing §/±, which is usually left of 1, and vice versa. I've checked Keyboard preferences and its set as British Mac keyboard, but the layout image is wrong, this is what I get:

keyboard preferences

Whilst this is what my friend gets, and what I would expect (this one also matches a UK Mac keyboard layout whilst mine does not):

enter image description here

The keyboard on the Macbook itself works fine with the correct keys.

I think this may have gone wrong when I installed the latest macos update.

The options panel offers very little flexibility, I've tried swapping to a US keyboard and deleting the British layout then adding it again but no luck. Anyone know how to correct this?

3 Answers 3

15

Your machine thinks your keyboard is of the ANSI type when it is actually of the ISO type. According to the article "Fixing Keyboard Type Problems":

Sometimes a machine will forget which type keyboard is attached, with the result that certain keys get transposed from what the user expects. The fix for this is run the Keyboard Setup Assistant again. Sometimes there is a button for "Change Keyboard Type" visible in System Preferences/Keyboard. If not, you can try trashing the file /Library/Preferences/com.apple.keyboardtype.plist

Another possibility may be to open Terminal and type:

sudo open /System/Library/CoreServices/KeyboardSetupAssistant.app/Contents/MacOS/KeyboardSetupAssistant

Sometimes, when JIS is involved on a laptop, one may have to follow the procedures in the SMC Resetting instructions. If none of those work, this Karabiner option may be helpful.

3
  • 2
    Please: cite and quote this link only answer; anyway.+ Nov 6, 2017 at 23:34
  • 1
    Ah that makes sense, I didn't know the layout it was suggesting I had was ANSI. Followed the instructions on the link that you provided specifically deleting the keyboard plist and then rebooting, that brought up the keyboard setup assistant again which correctly identified my keyboard as ISO. Not sure why that happened in the first place, I believe it changed after the latest macOS update but all is well now, thanks!
    – matthewrk
    Nov 7, 2017 at 13:24
  • Thats helps, but layout is still reset after re-connecting keyboard, and you need to re-run assistant again
    – Xotabu4
    Sep 11, 2019 at 13:49
1

I had a similar problem (another language - Swedish).

What finally helped me was to run "Change Keyboard Type..." and pressing the REVERSE key from what it expected. It then presents the wrong keyboard type, but just accept that one.

Then run "Change Keyboard Type..." again, now with the correct key and the correct layout will be presented. Accept that one, and now everything works again (for me).

1

Oh wow, following the advice from Erik I finally got it working with my austrian german keyboard layout. Microsoft Natural Ergonomic Keyboard 4000.

From left to right the keys of interest are: (LEFT SHIFT) (<>) Y X ... (,;) (.:) (-_) (RIGHT SHIFT)

I had to: (Mac OS Ventura)

  • Invoke "Change Keyboard Type..."
  • When asked for the key immediately right from the left shift key, I had to press the key immediately LEFT from the RIGHT SHIFT key. That is the (-_) key on my keyboard.
  • Then I got asked for the key immediately LEFT from the RIGHT SHIFT key, there I had to click again on the opposite key, that was the (<>) key.
  • Then Mac OS presented me with the result that I have an ANSI keyboard and I had to change to ISO.

Finally it worked and my keys are where they should be. :D Crazy...

(PS: When following the instructions from the keyboard assistant it also results in an ISO keyboard. Nevertheless the keys are wrongly mapped then.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .