2

Today I wanted to get rid of the old Bootcamp partition of my Mac. I used disk utility to remove the partition, which worked well. However, it seems like Disk Utility failed to correctly extend the main (Macintosh HD) partition, which still has the old size of 260 GB (of 500 GB disk size).

Main Disk Utility View

I tried to use the partition dialog, which initially shows this:

Disk Utility Partition View

Adding a new partition using + and then Apply fails with an "internal error".

First Aid on the drive succeeds, but does not fix the problem. I already tried all these steps in recovery mode, which shows the same views and behaves exactly the same.

Is there a way to fix the drive/partition?

The device in question is a MacBook Pro 15-inch Mid-2012 with macOS High Sierra v10.13.1.

1

I'm wondering if selecting the "View" button, followed by "Show All Devices" might shed some light here?

"Show all Devices" Menu Entry

Usually when I have trouble partitioning and it involves the drive I'm booted from, I will start up from Internet Recovery Mode or (preferably, for loading times) a version of macOS I've previously installed on an external hard drive or USB. Regular Recovery Mode might be fine as well, but it's still booted from the hard drive you're working on.

Internet Recovery can be started by holding the Option, Command and R keys while the computer turns on (you can let go once a globe icon or Apple logo appears).

Before you're starting up to do this, make sure you have a current backup!!! :)

One other thing I can think of that would stop you doing this is if macOS had to move the Recovery HD partition to be between your Macintosh HD partition and your Boot Camp Partition. It doesn't always have to do that, but if it does, you might have to manually delete the Recovery HD partition via Terminal and then expand Macintosh HD.

I'd suggest you use Apple's "Recovery Disk Assistant" to make a Recovery HD on an USB or external Hard Drive before doing that, in case you need to reinstall later, cause I don't think you can put Recovery HD back on the internal drive without a Major OS upgrade (like 10.12 > 10.13) or a reinstall.

If you run:

diskutil list disk0

in Terminal, it will give you a listing of all the partitions on the first mounted disk.

If there is a volume labeled "Recovery", and then a unformatted amount after it, that's why you can't expand Macintosh HD, but if it lists empty space and then the "Recovery" after that, then you can probably just expand Macintosh HD with a external hard drive version of macOS or Internet Recovery.

And again, Backup all your files first please!!!!

0

I saw this today on an iMac; a 1TB drive had been partitioned into four 250GB partitions and only one was in use! So I removed the three partitions that were not needed and Disk Utility confirmed the one left was 1GB.

However, in Finder, it still showed as 250GB. Even after a reboot.

So I'm still looking for a simple solution.

Having said that, this is likely to work:

Backup the system to Time Machine. Boot into recovery mode and then erase the 1TB. It should now appear as 1TB in Finder. Then restore from Time Machine.

...but ideally, there ought to be a quicker solution.

You must log in to answer this question.

protected by Community Nov 9 '17 at 7:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .