19

I'm seeing an error every 10 seconds in the system log, using the Console app, complaining about MirrorDsiplays service only running for 0 seconds.

Nov  5 22:45:22 computer com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
Nov  5 22:45:52 --- last message repeated 2 times ---
Nov  5 22:45:52 computer com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
Nov  5 22:46:22 --- last message repeated 2 times ---
Nov  5 22:46:22 computer com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
Nov  5 22:46:52 --- last message repeated 2 times ---
Nov  5 22:46:52 computer com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

It doesn't matter if I have no external display or use both displays at the same time. How do I turns off this warning/error in the logs?

  • I'm using macOS High Sierra v10.13.1, and this is happening to me, too. (1 external 4K TV with the lid down) – Martin Romañuk Nov 8 '17 at 13:33
6

I had the same log complaints. They are the result of macOS detecting the secondary HDMI display and some code quality issue.

Uncheck "System Preference > Display > Show mirroring options in the menu bar when available." After reboot the log output will be gone.

  • 4
    Unchecking "Show mirroring options..." didn't work for me. The messages started showing up right after I rebooted. – Jistanidiot Mar 8 '18 at 17:56
  • Can confirm - that’s not it. – Ranza Jul 2 '18 at 16:12
  • I have a hunch that AirPlay is implicated in some way. I get this error (and the powerchime one) on my old MacBook Pro 2010 (no AirPlay Mirroring support) If I try and enable "Show Mirroring Options..." in the Display preferences panel, I see the menu bar item briefly appear and crash out. – jrg Mar 13 at 22:28
3

I was able to resolve this problem on my system by modifying the LaunchAgent file to only load in the LoginWindow.

In addition to eliminating the errors every 30 seconds in the log, it also appears to also have resolved an issue where my display would not turn off, regardless of the setting in Energy Saver. So, I'm pretty happy.

The steps I took were as follows:

  1. Disable System Integrity Protection so you can edit the .plist file. Do this by rebooting into the recovery partition with cmd-R, open Terminal from the Utilities menu, and type:

    csrutil disable
    
  2. Reboot into yoru system, then edit the .plist file with this command:

    sudo vi /System/Library/LaunchAgents/com.apple.preference.displays.MirrorDisplays.plist
    
  3. Comment out the line that causes the MirrorDisplays tool to load. Change this line:

          <string>Aqua</string>
    

    to this:

    <!--  <string>Aqua</string>   -->
    
  4. Then, reboot and reenable System Integrity Protection using the recovery partition as described above and type:

    csrutil enable
    
  5. Reboot and enjoy a clean log file!

  • Thanks, but this didn't work for me. It still launches and the machine crashes regularly on a vanilla 10.13.5 with just FileMaker Server and TeamViewer installed. I suspect the repeated launching has something to do with receiving a TeamViewer connection, but have not investigated it deeply. I "fixed" it by renaming the executable MirrorDisplays to something else so it cannot be launched. Not sure what other effect this may have elsewhere, but as this is a server, I don't care about the display features. – AndreasT Jun 18 '18 at 6:49
  • 1
    @AndreasT: Editing com.apple.preference.displays.MirrorDisplays.plist to comment out the Aqua string, as described above, prevents the MirrorDisplays executable from being invoked while the Mac has a user logged into an interactive session. It may be that, for your purposes with an unattended server, you need to also comment out the LoginWindow string on the preceding line, which should have the same effect when the Mac has no one logged in interactively. Let me know if this works! – jdmc Sep 11 '18 at 19:04
  • @jdmc, I won't be able to test this out but your idea sounds plauible. – AndreasT Sep 12 '18 at 13:11
  • 1
    No, do not tell people to "csrutil disable" without a dire warning. – ruief Oct 14 '18 at 22:12
  • Ruief, all this paranoia about "csrutil disable" is childish alarmism. We all ran our Apple computers without csrutil. Csrutil is useful to prevent newbies and iPhone users from easily being hacked. It's also very useful to lock Mac users out from being able to administer our own computers and turn us into iPhone users. Dire warnings is pointlessly alarmist language. AskDifferent and SuperUser are not nursery school. – Foliovision May 3 at 7:51
2

Editing the plist file as explained in Carl Hewitt's answer caused windows that extended across two monitors to only show on one of the two screens. The other portion of the window simply disappeared.

The following resolved the issue for me: Launch System Preferences, select Displays and uncheck "Show mirroring options in the menu bar when available."

System: 2017 27" iMac High Sierra 10.13.6 with two additional 27" ASUS displays connected via HDMI at the display. Credit to Allan & Bath Thank you.

  • I have that preference unchecked yet I see the error message – odysseus Sep 11 '18 at 15:18
  • Re: "caused windows that extended across two monitors to only show on one of the two screens. The other portion of the window simply disappeared." — This is the normal expected behavior if the "Displays have separate Spaces" option is checked (enabled) in System Preferences > Mission Control. Is yours checked? If so, uncheck it, and then reboot (or at least log out and in again). Then all displays will be treated as a single extended desktop area, with windows free to straddle different screens. However, the menu bar and Dock will appear only on the main display, rather than all displays. – jdmc Sep 11 '18 at 19:16
2

Unchecking "Displays have separate Spaces" in System Preferences → Mission Control worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .