2

How do I prevent the following dialog from appearing in Safari. I don't see why Adobe would need certain information. Since "deny" doesn't seem to impact anything, I would like to "Always Deny". I have already disabled the adobe plugins within Safari. I am observing this in the latest High Sierra. I have latest Acrobat, Illustrator and Photoshop installed through Adobe Creative Cloud.

enter image description here

1

I cannot add a comment so I am posting this as answer. Can you share a screenshot of your activity monitor. Since plugin is requesting keychain access for Acrobat, Acrobat safari plugin process should show in Activity monitor. Also are you getting this even when not opening PDF?

While opening PDF on Safari doesn't need any keychain access in itself, Acrobat services are available in browser too and since these are paid, it needs to check user login for which keychain access is required. Unfortunately Apple doesn't give a Deny Always.Check Here.

You can try adding safari plugin process to allowed application in keychain "v4.services.acrobat.com". The process is /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.Plugin .64.xpc. Please note that this will actually allow access to plugin process and won't ask you again. Use keychain Access app, search for keychain item "v4.services.acrobat.com" and add this in allowed application. This is what Always Allow effectively does.

If you are not interested in opening PDFs on Safari, you can delete Acrobat plugins from /Library/Internet Plug-Ins/. Its named AdobePDFViewer,AdobePDFViewerNPAPI. Or move them to disabled. This would definitely fix it but you wont be able to open pdf on Safari using Acrobat.

  • thank you; I will investigate activity monitor the next time; presently the dialog box appears rare, and pdfs are opened through Preview within Safari. – tsttst Nov 17 '17 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .