7

I'm using Postfix to forward emails from my Mac through smtp.gmail.com.

Following recent security update (https://support.apple.com/en-us/HT208221) Postfix fails to forward emails with the following errors:

smtp: warning: Digest algorithm "md5" not found
smtp: warning: disabling TLS support
smtp: TLS is required, but our TLS engine is unavailable

Here is a snippet from Postfix main.cf.

relayhost = [smtp.gmail.com]:587
smtp_generic_maps = hash:/etc/postfix/generic
smtp_tls_security_level=encrypt
smtp_sasl_auth_enable=yes
smtp_sasl_password_maps=hash:/etc/postfix/sasl/passwd
smtp_sasl_security_options = noanonymous
smtp_sasl_mechanism_filter = plain

Any ideas how to get this working again?

  • Same issue posted on Stackoverflow... no comments yet -- stackoverflow.com/questions/47111296/… – BenL Nov 9 '17 at 0:09
  • @BenL please note that upgrade to High Sierra (10.13.1) fixed the issue for me without any configuration changes. – Early Bird Nov 9 '17 at 8:51
  • Awesome, Thanks. I will upgrade as soon as I am ready to tackle the rebuilding of my dev environment that an OS upgrade will entail. – BenL Nov 10 '17 at 12:22
1

I also upgraded to High Sierra and that fixed the issue for me. I have been trying for a week to find a solution.

|improve this answer|||||
  • Upgrading to High Sierra also fixed the issue for me. – user3261593 Nov 15 '17 at 3:02
  • I'm on Sierra, heard bad things about High Sierra, any solution that doesn't involve upgrading to High Sierra? – Chris Withers Nov 26 '17 at 23:38
1

I got postfix working again on Sierra by installing (and configuring) postfix from macports. Upgrading to High Sierra is currently not a solution for me because my system disk is an AppleRAID.

|improve this answer|||||
  • Can you PLEASE explain exactly what you did? I have tried installing postfix from macports and I got the same error. – JBis Mar 17 '18 at 1:18
  • Looking at my .sh_history, it looks like I just followed the instructions on this page. – mtl Mar 19 '18 at 13:16
  • Also, I think you have to run the following commands: $ sudo port load postfix $ sudo launchctl unload -w /System/Library/LaunchDaemons/org.postfix.master.plist – mtl Mar 19 '18 at 13:22
  • # A startup item has been generated that will aid in # starting postfix with launchd. It is disabled # by default. Execute the following command to start it, # and to cause it to launch at startup: # # sudo port load postfix ... postfix has the following notes: To get postfix working, you need to edit the configuration files (/opt/local/etc/postfix/*). You may also want to turn off Apple's built-in MTA. For example: sudo launchctl unload -w /System/Library/LaunchDaemons/org.postfix.master.plist – mtl Mar 19 '18 at 13:25
  • LIFESAVER! I think that command is the solution. Will try tomorrow. I have littlerly been trying to get enough points to comment just to comment on this post. Thanks! – JBis Mar 20 '18 at 0:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .