enter image description hereenter image description hereI installed high Sierra a few months ago and nowadays there seems to be a problem with System Information.app, it always shows the disk usage wrong like for example System 40GB but it shows photos to be 0KB even though I have 19GB worth photos and DaisyDisk reports correct disk usage. so how do fix this?

PS.

I have also tried booting into safe mode and rebooting.

Screenshot: enter image description here enter image description here I have run this scan as root user not admin.

  • do you have cloud sharing turned on? – jmh Nov 5 '17 at 7:04
  • Yes I do. Should I Disable it and my cloud storage plan is 5GB and I used all of it. – user244378 Nov 5 '17 at 8:24
  • Could you specify what figures of used/free space are displayed by DaisyDisk? And also by Disk Utility and Finder's Get Info? – swa16 Nov 9 '17 at 9:03
  • Yes I will upload it shortly.swa16 – user244378 Nov 9 '17 at 11:42

I recently ran into this - on my 500GB SSD, my free space was only 5% where I expected more like 75%. I found an answer in a blog that worked for me:

Apple state that they automatically remove local snapshots when disk space is low, but their definition of low is apparently only 5GB of free space remaining – not really much free working space in 2017 when you might want scratch space of 22GB for 1 hour of 4k 30FPS footage.

On older MacOS releases, it was possible to disable the local snapshot feature entirely, this doesn’t seem to be the case with High Sierra – but it does appear to be possible to force an immediate purge of local snapshots with the following command:

sudo tmutil thinLocalSnapshots / 10000000000 4
  • You may want to include a brief summary of the blog entry. Consider the value of your answer to readers who have printed out on paper. – Thorbjørn Ravn Andersen Sep 23 at 20:34
  • Best. Command. Ever. Just purged 160GB of TM snapshots to make space for MY stuff. – Tuminoid Oct 4 at 17:36
  • Greatest command ever! – Brady Oct 14 at 15:19

Most likely the space is taken by Time Machine. It keeps making local snapshots when the persistent TM storage is not available. The local snapshots can pile up to as much as 80% of disk space. After the next backup, or when the disk space runs low, the local snapshots are automatically removed by macOS. So this is not really a problem that needs a fix, the system will take care of it.

That said, I'd agree that the System Information app needs a fix on High Sierra. It seems to include the local snapshots into "System" category and therefore it appears as used space, while Finder counts the snapshots as "purgeable", including it into the "available" space. This inconsistency is confusing.

DaisyDisk currently includes the snapshots into the used space (as opposed to Finder). Previously the snapshots could be revealed (./MobileBackups folder) when scanning "As Administrator", but starting from High Sierra and APFS, the local snapshots are saved outside the scannable area, so DaisyDisk simply shows a bigger "hidden space" segment. An update of DaisyDisk is said to be coming that will display purgeable space more consistently with Finder: https://daisydiskapp.com/manual/4/en/Topics/HiddenSpace.html?subtopic=StillHiddenSpace

  • 1
    But I don't use time machine do backup I use rsync – user244378 Nov 8 '17 at 1:12

I had a similar problem just now: Finder, "Get Info", and Disk Utility were all reporting 18GB free on a 250GB SSD that should have had plenty of free space. Under "About this Mac"->Storage, it reported 130GB of "System" usage. None of the space was listed as "purgeable", and macOS started complaining about lack of disk space.

I found a solution in this Apple discussion thread. In my case, the problem was fixed by going to Time Machine Preferences and removing an old backup drive (that had long ago died) from the list of backup drives. Immediately, the available disk space on my SSD started being reported correctly as 120GB.

  • This worked for me as well. – Jan Jan 7 at 14:25

You need to reindex your Spotlight cache. To do this

  1. Go to System Preferences → Spotlight → Privacy
  2. Click on the plus symbol and add your macOS hard drive you're having the wrong status/info problem
  3. After adding your particular hard drive, quit System Preferences then wait for a few seconds.
  4. Again open System Preferences → Spotlight → Privacy and this time remove your previously added hard drive.

What this does is it reindexes and creates the .Spotlight-V100 files on your hard drive. There are also various sudo commands to perform this step but for now try this!

  • I tried the method but it's taking a lot of time to index so once it finishes I will approve your answer – user244378 Nov 8 '17 at 12:24
  • This answer doesn't solve my problem but I think spotlight is not indexing my photos because I have 20 gigs with photos but it shows 0KB so I think I will add my pictures folder in spotlight>Privacy like how you told me to add my main hard drive. – user244378 Nov 8 '17 at 12:54
  • I tried but nothing seems to work can you help me around this problem. – user244378 Nov 8 '17 at 13:55
  • @Geek Upload a screenshot of your Storage Status and spotlight privacy Tab and did you added the entire hard drive or only the Photos folder? – Sayan Nov 8 '17 at 17:56
  • At first I added my whole hard drive then I added my pictures folder. – user244378 Nov 9 '17 at 2:17

I found that just opening the Storage Administration window (in System Information) fixed this.

This was important as I needed to restore my photo library from Time Machine and throwing the broken folder in the trash and emptying the trash did not release the diskspace. Disk Utility said there were five snapshots on the disk which most likely was the culprit.

I solved this issue just relaunch finder. Click on apple logo->Force Quit->Finder and click Relaunch. So I opened my finder and it shows the correct size.

protected by Community Jun 18 at 20:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?