11

This question already has an answer here:

I've taken over my wife's Mac mini running osx high sierra. I was in a rush and went into system preferences, clicked on the current user (advanced options), which was named 'user', which was also the administrator, and changed the name to 'grant'. This didn't end up changing the username. I then tried to create another administrator user called 'grant'.

I logged out. When I logged back in the only user available to log in with was 'user'. When I opened user preferences I see that 'user' is no longer an administrator.

I now have no way of accessing an administrator. When I try move files into the applications folder it asks for admin username and password. I've tried every combination of 'user' and 'grant' and nothing works.

Any help getting me access to an admin user will be appreciated.

enter image description here

Here is the screen where I try remove the file in single user mode enter image description here

marked as duplicate by grg Feb 8 '18 at 23:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I have a question - was the Mac mini already on macOS High Sierra before you took over your wife's Mac mini? Or did you upgrade it? If you did the upgrade, at what point did you upgrade in relation to your changes to the User accounts? Basically, if you did the upgrade, in what order were things done? – Monomeeth Nov 5 '17 at 8:10
  • @Monomeeth It was on Sierra. I then upgraded to High Sierra. I then fiddled with the username. – spuggy Nov 5 '17 at 8:12
  • Ok, I think I have a solution for you - but I'm running late as I have to be somewhere. Will update my answer in about an hour. :) – Monomeeth Nov 5 '17 at 8:16
  • Yes I only saw your update answer after I posted the screenshot. All is resolved. Thank you so much for taking the time to answer. – spuggy Nov 5 '17 at 21:37
8

If it's not already, make sure your Mac mini has an up-to-date backup.

Then follow these steps:

  1. Shut down your Mac mini
  2. Power up your Mac mini and immediately press and hold the command + S keys
  3. Keep the keys down until you see text on the screen
  4. Now enter the following command:

    /sbin/fsck -fy

    and press enter

  5. Next enter the following command:

    /sbin/mount -uw /

    and press enter

  6. Now enter the following command:

    rm /var/db/.AppleSetupDone

    and press enter

  7. Finally, enter the reboot command

    and press enter

Your Mac mini should reboot and you can log in normally, after which point the Setup Assistant will launch. Now you need to create a new admin user. Don't worry, your other user accounts should be intact. NOTE: You should choose a new user name for this admin account.

Once you're back up and running you can go to Apple > System Preferences > Users & Groups and select the Allow user to administer this computer checkbox for the 'grant' user.

  • I have the same problem but with a macbook pro. is the procedure the same? thanks – Tomas Nov 7 '17 at 0:40
  • 1
    If it's the same problem then yes, the above steps should help you resolve it. :) – Monomeeth Nov 7 '17 at 1:37
  • 1
    This fix solve the problem on MacBook Pro with Hight Sierra.. thanks – Malek Boubakri Feb 18 '18 at 7:46
  • 1
    On high sierra step 6 does not work: /var/db/.AppleSetupDone because the file is only for reading. – Fusion Apr 28 '18 at 14:07
  • @Fusion mount -uw / mounts the FS as read-write. You have to or else you can't remove the file because the disk is read-only. – Dev Oct 6 '18 at 22:25

Not the answer you're looking for? Browse other questions tagged .