2

I've been having issues with my MacBook Pro randomly shutting down for about 2 weeks now.

I tried taking it to a local Apple reseller and here's what they told me:

  • The main cause of my problem was because I was using f.lux
  • They tested the battery and it apparently said that "the battery test failed". I'm not even sure what that means.

I tried all the different tools to check my hardware and software, I ran the Apple Hardware Test and the only thing I got is:

4HDD/11/40000000 SATA(0,0)

I checked if there were any malware or viruses on the computer but every program I used points to the same conclusion: everything is going fine. I tried SMC and PRAM reset, I even formatted the SSD and reinstalled macOS High Sierra but the problem still occurs.

Here are my console logs, I took the first 25 lines just before the BOOT_TIME: https://pastebin.com/QMjiwx72

I tried the syslog | grep shutdown command in the terminal and here's what I get:

Nov  4 21:39:15 macbook-pro-de-sylvain shutdown[939] <Notice>: SHUTDOWN_TIME: 1509827955 280191
Nov  4 21:39:37 localhost com.apple.xpc.launchd[1] (org.cups.cupsd) <Warning>: Service has increased maximum shutdown time to 60 seconds. This will create a poor experience for the user.
Nov  4 23:55:06 localhost com.apple.xpc.launchd[1] (org.cups.cupsd) <Warning>: Service has increased maximum shutdown time to 60 seconds. This will create a poor experience for the user.

I really don't know what to do anymore... I've been looking for a solution all over the web but I couldn't find any fix.

Does anyone have any idea about what could be going on? :(

Thanks in advance,

Sylvain

  • If he says that the battery fails, it's probably not a good thing. I think you should bring your computer to an  Apple Store, because they will be able to do some hardware diagnostics for free in seconds. I know that it might be more interesting to repair your Mac in a retailer store, but you'll loose your warranty. And by the way, f.lux shouldn't be for anything, I have it on my Mac for almost 2 years and I had no problem. – Arthur Guiot Nov 5 '17 at 0:39
1

Credit: https://discussions.apple.com/thread/5497782?tstart=0 This error indicates that you might have a fault Connection or the drive itself is failing. If you have the original drive that came with your Mac you can check the S.MA.R.T. status by running diskutil info disk0 | grep SMART in terminal if it returns failing then time to get a new drive or if it is returning Verified then it might be a faulty connection take it to a authorised apple store and they might fix it for you.

1

I realize it's been a long time since the initial post and unfortunately I don't have a solution, but I'm going through what appears to be the same problem and, as there seems to be scant documentation, I thought I'd report a couple more details to see if they jog any ideas in anyone and if they line up with your original report. On running syslog | grep shutdown I get the same response:

localhost com.apple.xpc.launchd[1] (org.cups.cupsd) <Warning>: Service has increased maximum shutdown time to 60 seconds. This will create a poor experience for the user.

On contacting support, Apple is also presuming this to be a battery issue, but they (or anyone else for that matter) can't explain how/why the spontaneous shutdowns would occur when on AC power.

So, a couple things I've noticed:

  1. Running yes > /dev/null & in terminal prevents the random shutdowns. I've seen this workaround in a couple places but not connected to the 'maximum shutdown time' we're both getting

  2. While running gfxCardStatus to lock the graphics card to either integrated or the discrete nVidia card, I get different shutdowns.

On integrated graphics:
- I get a black screen, but with the LED panel clearly still on and the keyboard backlight stays on (if it was on before). The fan runs loudly and the black screen remains for about 10 seconds, then the computer shuts down.
- to my best recollection, this only happens on battery power.

On discrete cards: - rather than going black, the screen freezes. The rest is the same (fans, shutdown after about 10 seconds) - happens on both ac and battery power

Anyways, hopefully that spurs some idea in someone. Seems like everywhere I look or anyone I talk to has different advice on cause and solution, but your original question is the only one I've seen that's exactly the same as what I'm going through (with the minor exception that my laptop is a late 2013 15" model).

  • Hey Sean, thanks for your answer! I don't know if that might really help but in the end I took my MacBook to the store and they told me the motherboard was sort of dead... So I had to buy a new MacBook because I need to use my computer every day. I really relate to what you wrote, I googled everything I could at the time but I was finding a different answer every time for the same issue. Maybe you should take your Mac to the store and see what they tell you about it. Have a great day :-) – Sylvain Roulin Dec 13 '18 at 8:00
  • Remember that running yes > /dev/null & makes the CPU run at 100% – Daniel Nord Jun 19 at 7:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .