2

I am using Sierra 10.12.6 and by using Homebrew, vsftpd is installed so that I can set up an FTP server my iPad can connect to.

However, I can't run the command vsftd:

zsh: command not found: vsftpd

But when I try to install vsftpd again, i see that

*Warning: vsftpd 3.0.3 is already installed

I can do man vsftpd and that works fine.

I run which vsftpd at root, this returns vsftpd not found

I went to the vsftpd config file and also set listen=YES

So how do I run vsftpd?

  • Ok, I was finally able to locate vsftpd /usr/local/Cellar/vsftpd/3.0.3/sbin, but why doesn't which command work? – zcahfg2 Nov 3 '17 at 20:21
1

vsftpd needs to be in your PATH

If it's not in your PATH, it will not run nor will you be able to find it with the which command.

You can add it two ways:

  • Append your PATH to include the directory /usr/local/Cellar/vsftpd/3.0.3/sbin
  • Make a symlink to vstpd in your /usr/local/bin directory

I would choose the second option as you have less items to modify (.bash_profile for example):

sudo ln -s /usr/local/Cellar/vsftpd/3.0.3/sbin/vsftpd /usr/local/bin/vsftpd

That said...I wouldn't be using an insecure protocol like FTP to transfer files - scp is a much better option. See this blog for details

  • This Ipad app I am using only supports FTP streaming that was why I wanted to learn how to set up FTP server. But thank you for such a kind answer. I will read up on scp blog you mentioned. Thanks a lot. – zcahfg2 Nov 3 '17 at 20:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .