2

I have an iPhone that is running out of space. I have added the Google Photos app and sync'd all photos to it. I deleted photos from the native phone app. That freed up space but now I have an issue with my Messages app. It has several gigs of space taken according to the storage panel in settings. Message is the number #1 app using my storage, a few gigs! I went into Message and deleted all of the messages but it did not register that the space is saved, so it still lists it in the storage panel as using a lot of space. I have about 20 megabytes left on my phone.

1

Go to Setting>Messages>Message History> Keep Messages> Choose 30 days. It will delete the ones taking up your storage. You can switch it back to Forever if you don't want your new messages deleted in 30 days.

  • Thank for you the reply, Melvin. I tried that and it didn't make any change. I had previously manually deleted all of the texts/iMagesses myself so it seems like the iPhone isn't realizing the space can be freed up from memory. It's like it didn't register the deletions. – J Dillinger Nov 3 '17 at 20:41
  • Then it has to do with some of your attachments. Go into the Settings app and navigate to General > iPhone Storage. Scroll down the list and select the Messages app. From there, tap on “Review Large Attachments”. This will provide you a list of every single photo, video, and other attachment that the Messages app has saved from all of your conversation threads, and it’s in order by largest size first. To delete them just swype to the left on each. – Melvin Jefferson Nov 3 '17 at 20:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .