1

I have recently purchased a SSD (Samsung 850 EVO 250GB 2.5-Inch SATA III Internal SSD (MZ-75E250BW) ) I followed following steps in order to do the clean installation:

Step 1: Terminal > "diskutil erasedisk hfs+ External GPT /dev/disk2"

Step 2: Plugged a 16GB USB and Tried creating bootable with - Terminal using command and also tried with "Disk Creator".

Step 3:

Restart the mac > Hold the Option Button > Selected the 16GB Drive and Selected the option of installation on the new SSD. [The SSD is formatted via APFS format. Tried with Mac OS Extended (Journaled) as well.]

Note: the SSD after installing High Sierra works flawless while connected externally via USB, but shows the "Prohibitory Symbol" when attached internally and loads the OS after 10 minutes and its very slow.

Don't want to try Carbon Copy Cloner as i tried and when i connected the SSD internally it was same.

Tried:

  • Boot in safe mode: Same Results. No change.
  • Reset NVRAM - Same Results. No Change.
  • resetting the SMC - Same Results. No Change.
  • Diagnostic Test. ( No Problems found )

Currently the thread is also upon at This Website

My Macbook Pro Configuration

  • MacBook Pro (13-inch, Mid 2012)
  • 8 GB 1600 MHz DDR3 Thank You in advance.
  • Pure guess... your external enclosure is using a 'fake' block size, which is messing up the drive when mounted internally. [I also don't know how to fix that, short of not formatting the drive in that enclosure] – Tetsujin Nov 3 '17 at 20:19
  • It works super awesome when plugged via USB, when i mount inn, it just goes bad. I am not sure what is 'fake' block size too. :( Thank for the inputs @Tetsujin – Deep Rathod Nov 3 '17 at 20:24
  • I have to admit I don't really comprehend any of this, but it's something I've seen on Super User a lot - this looks like a fair explanation... superuser.com/questions/679725/… [Note: I'm not even aware if this can affect Macs, I've just seen it as an issue on SU often enough that it rang a bell] – Tetsujin Nov 3 '17 at 20:32
  • @klanomath thank you for replying. So what should i do now ? Its currently fitted internally only. Should i format again ? I am sorry, I couldn't interpret what to do actually. – Deep Rathod Nov 3 '17 at 20:48
  • @DeepRathod Booted to the thumb drive, open Terminal.app (menubar > Utilities), partition the internally attached ssd with: diskutil eraseDisk JHFS+ SSD APM /dev/disk0. Then diskutil eraseDisk JHFS+ SSD GPT /dev/disk0. Then quit Terminal and install macOS High Sierra to "SSD". – klanomath Nov 3 '17 at 20:54

You must log in to answer this question.

Browse other questions tagged .