1

This has been answered repeatedly, but I keep running into a problem. I am trying to add a new administrator account to my computer via the single-user mode in the terminal.

The /sbin/mount -uw / command works fine. However, whenever I type in rm /var/db/.applesetupdone, it gives me an override prompt. I have typed in 'yes', 'y', and 'override'. 'Yes' and 'y' both give me this message: rm: /var/db/.applesetupdone: Permission denied. 'Override' does nothing.

Can someone help me with this?

  • Preserve case even if the filesystem is not case sensitive. The file is named .AppleSetupDone. How does removing this file help you add a new administrator account? – fd0 Nov 3 '17 at 18:23
  • First, run mount with no arguments, and make sure "/" isn't listed as readonly. Second, try ls -ldeO /var/db /var/db/.AppleSetupDone, and see if it shows any weird permissions or flags. /var/db should have the "sunlnk" flag, but that's all. – Gordon Davisson Nov 3 '17 at 20:44
1

I think you're missing a step, namely the /sbin/fsck -fy command. After logging into Single-User Mode, enter the following commands in the order listed:

  1. /sbin/fsck -fy

  2. /sbin/mount -uw /

  3. rm /var/db/.AppleSetupDone

This should negate the need to override.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .