1

I have a development environment that uses the Pow webserver. When I initially set it up, it automatically reconfigured the firewall to allow me to connect to my_project_name.dev urls.

Last time I upgraded to macOS Sierra, that stopped working. Every time my MacBook reconnects to the network, I have to run sudo pfctl -f /etc/pf.conf before the firewall rules allow me to access the .dev urls that Pow configured. From what I've read, macOS's Application Firewall is supposed to start pfctl automatically. Why isn't this working? Where should I start looking to troubleshoot this?

  • 1
    The alf should start pf, but it does so with certain oddities. Your answer might be here: PF on Mac OS X – LangLangC Nov 2 '17 at 16:55
1

A workaround which worked for me:

  • System Preferences -> Security & Privacy -> Firewall -> Firewall options -> Check "Enable stealth mode"
  • Reboot
  • Check if pfctl is enabled now, in a Terminal:

    sudo pfctl -s info | egrep -i --color=auto 'enabled|disabled'
    
  • Upgrading to High Sierra mysteriously resolved all my issues! I'll take your word that this fixes things. :-) – James Jan 30 '18 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .