Once upon a time I had a Link to the Harddisk directly on my desktop. Since I set up Lion, the Link is not there anymore.

How can I make it appear again? Drag & Drop from Finder doesn't work.

4 Answers 4


The normal solution is to go to finder preferences, and select the things (including hard disks) you want to show on your desktop. If your hard disk is external, I think you can create an alias (Right Click > Make Alias) and put it on your desktop, to represent it even when the actual disk isn't connected, not that it would allow you access to the files on this hard disk.


Go to Finder's Preferences, then in the General Tab, check the "Hard Disk's" (or external depending on what hard disk you're talking about) box. It should show up on your desktop now.


The answer from @abc9005 and @theAmateurProgrammer are correct for the case where you have only 1 internal harddisk or have multiple internal hard disks and wish to show them all.

When you have multiple internal hard drives and wish to only make the Startup Disk visible on your OSX Lion desktop, and your Startup Disk is named "Macintosh HD" then you can use this Terminal.app command:

$ ln -s "/Volumes/Macintosh HD" ~/Desktop

You can also go to the "Go" menu in Finder. Then type /Volumes.

Copy the alias to the Macintosh HD, from there to your desktop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .