5

I downloaded the High Sierra upgrade a few weeks ago and have tried to launch it now and then since, but it does nothing. Not even report an error.

The High Sierra icon with apparent stalled download indicator in my Applications folder High Sierra icon

It does seem to start. I'm pretty sure I can see it when I run top in a terminal.

My machine is officially compatible. It's a mid-2013 11" MacBook Air.

It doesn't have an SSD, just a USB 3 external hard drive. But this didn't stop the last few OS upgrades from working.

I can't seem to find this specific problem mentioned anywhere on the net when I Google for it.

Is this actually a known problem with a solution?

Update

I thought I should try to run it from the terminal and see if it outputs an error there. But it is not a regular executable file. It is some kind of magical directory in fact that is associated with the App Store. So I don't know of a way to launch it from the terminal. Doubleclicking on it does something in the background using the App Store, since the App Store does not open or tell me anything.

  • 1
    Your comment at ProGrammer's answer: "The date was recent so I was sure that would fix it.". I don't see a recent "Install macOS High Sierra.app" in your screenshot. Even your iTunes and Safari are newer! – klanomath Nov 6 '17 at 12:59
  • @klanomath: Yes that's another thing! When I downloaded the update a few days ago the date in the app store was late October but the date on the icon in my Applications folder seems to be for the original time I downloaded it. The small size and indicated download percentage seem to also reflect the first download attempt rather than the recent one. – hippietrail Nov 6 '17 at 13:35
  • Search for an "Install macOS High Sierra.app" outside the /Applications folder. The file should have a size of ~20 MB (the stub installer which loads the full payload in a second step while installing) or > 5 GB (the full installer). Or remove the 408 KB ruin and redownload the High Sierra installer. – klanomath Nov 6 '17 at 13:40
  • There doesn't seem to be another "Install macOS High Sierra" anywhere so when I have a spare couple of hours I'll try deleting before downloading again. – hippietrail Nov 7 '17 at 6:00
  • 1
    @hippietrail I can verify that the macOS High Sierra file should be much bigger in filesize (as klanomath's comment suggests). I believe that your connection was probably interrupted at download. The installer is available in the Mac App Store and works! Are you able to go somewhere with a stable internet connection and start it again? Perhaps you can get someone in your circles to make you a bootable installer on a USB and send it to you, that's an alternative if you can't get stable connections at the library or home. Has there been any progress since you started this thread? – ProGrammer Dec 7 '17 at 3:34
1

Depending on when you downloaded the installer precisely, this answer may provide a clearer reason for the issue.

  • I have noticed that their have been one or two system updates for macOS High Sierra in the past weeks. The fact that you are encountering this issue is most likely due to the fact that your version is older than the currently available and up-to-date one in the Mac App Store today.

  • Please try downloading the latest version.

Then let me know how you get on with the install. This would be the only logical reason for it not working on a supported / compatible system.

  • I'll give it a shot ... – hippietrail Nov 3 '17 at 4:54
  • About three days ago I spent a couple of hours re-downloading the upgrade. The first time I was at a library where the connection would shut off every two hours so it might've gone wrong. This time it was in one hit. The date was recent so I was sure that would fix it. But now when I've had time to actually install it the exact same thing happens. I've noticed that in Finder the file size is still very small plus there seems to be a stalled download indicator there at about 1%. It definitely completed the download last time. It still fails silently with no errors or warnings. – hippietrail Nov 6 '17 at 12:08
  • @hippietrail I feel that I have adequately answered your question, what is the current status? Please consider accepting my answer by clicking on the checkmark next to it. – ProGrammer Jan 22 '18 at 22:57
  • I tried to upgrade again just a couple of hours ago after putting it aside for weeks. This time it failed telling me some file was missing and kept doing that in a loop three or four times that I managed to get out of. So still no High Sierra here and still not sure why. – hippietrail Jan 23 '18 at 3:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .