1

I have read the 'man atrun' page and ran the sudo command to enable at.

I did successfully create a scheduled job, but it does not execute the job at my scheduled time. I only have an at.deny and cron.deny file in /var/at. If I access /var/at/jobs, I can see the job I just created as an executable file. I then double-click the job and it then runs the job I scheduled in Terminal.

Do I need an at.allow file?

I am running High Sierra (10.13).

  • After I enabled atrun with the command mentioned in the manpage, I get periodic entries in the system log saying that atrun exited with status 1. If I run atrun manually (as root), it runs any pending jobs just fine. Does this match your experience? Maybe modify the launchd .plist file so that atrun gets passed the '-d' switch; judging by the source code, that should turn on some debugging output. I cannot test it at the moment as my High Sierra machine is turned off and far away... – Ture Pålsson Nov 20 '17 at 13:07
  • Tried again some days later, and then it worked, and I have absolutely no idea what I did differently. Oh well, at least it shows that it is not impossible... A friend reported it working on first attempt. I wonder what is going on here... – Ture Pålsson Nov 27 '17 at 8:33

You must log in to answer this question.

Browse other questions tagged .