1

I have a 2012 13" Macbook pro, running macOS Sierra. I have 2 hard drive set up, in the optical bay I have ssd with all system operation files. I'm trying to install a new hdd in normal hard drive slot, but for whatever reason can't erase it. I have tried plugging it externally, after I initialize it I can transfer files to it. Then I put it in hard drive slot and try to partition it but get an error. I have tried erasing disk in recovery mode and/or unmounting drive with terminal commands but I eventually get the same result enter image description here

enter image description here

enter image description here

I usually can figure out all that stuff, and it is not the first time I am installing new hard drive, but I can't figure it out for some reason

Progress update. Plugged disk externally, erased in in recovery mode. Plugged disk internally, gettin the same error. Unmounted through terminal commands.

Used sudo diskutil eraseDisk JHFS+ MacintoshHD disk2 to try and wipe disk completely. Got Error: -69825: Wiping volume data to prevent future accidental probing failed

Progress update. The issue has to be with the hard drive cable itself. Will update the question once I have a new cable

0

I've put in a new hard drive cable, and all the issues are fixed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .