4

A weird problem has showed up the last …weeks? The emoji viewer (Cmd+Option+Space on my keyboard) will trigger at random when I click an input field. At first I thought it was just a Slack bug, user error, or stuck keyboard keys, but the problem has showed up on my other Mac too. It's wildly annoying, as I have to hit Esc after I focus on any new input field. My only lead at the moment is assuming its macOS. The problem comes and goes seemingly at random too (haven't found a pattern yet).

I'm all googled out. Any ideas?

  • macOS 10.13 High Sierra
  • Norwegian keyboard layout
  • Bluetooth keyboard (identical setup on both Macs)
5
  • Does this happen in all apps? Oct 30, 2017 at 18:28
  • 1
    Is it the same BT keyboard you use for both Macs?
    – fsb
    Oct 30, 2017 at 19:37
  • 1
    @TomGewecke It appears to be all apps. Oct 31, 2017 at 9:02
  • 1
    @fsb Both are Apple BT keyboards, one first gen, one second gen (latest as of writing). Oct 31, 2017 at 9:03
  • 2
    Update for googlers: The problem has disappeared on its own. No hardware has changed so it must have been fixed by a software update (most likely a macOS update). Jan 27, 2018 at 21:29

3 Answers 3

6

Yes, this is super annoying!!! This worked for me on my 2020 M1 Macbook Air running Big Sur 11.2:

On certain Macs, pushing the FN key (which may have a "globe" it) can bring up an emoji keyboard. Disabling this shortcut can be accomplished by opening the System Preferences and navigating to the Keyboard panel.

From within the Keyboard tab, look for the label that reads Press "globe icon" to. It likely reads "Show Emoji & Symbols". Click on the dropdown and choose Do Nothing to disable the emoji shortcut.

enter image description here

Found this on https://appsliced.co/ask/how-do-i-disable-the-emoji-keyboard-shortcut-on-my-mac

1
  • Exactly what I was looking for Jun 16 at 23:19
2

I faced the same annoying bug with emoji viewer in macOS Mojave (10.14.6).

Possible solution

In case of multiple input sources, try to delete one of them (System Preferences -> Keyboard -> Input sources) and add deleted one again. System restart was not required in my case.

If you have only one default input source, try to add some another and then delete it.

I hope this solution comes in handy

0

Just had this issue, solution was to press function once to bring the menu up, then again to remove it. You can then stop function behaving in this way as mentioned in the other post (doing this first still causes the menu to appear on clicking inputs)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .