3

http://www.halfapp.co uses the 💯 emoji.

In Safari on macOS I see a question mark in a square. See screen.
I also have this issue in emoji used on my Instagram profile.

Also, in the web inspector, I see the emoji.
And if I use Look Up, the emoji is shown.
Logging in as a guest user I see the emoji.

No duplicate fonts, no fonts with errors.
Apple Color Emoji is where it should be.

And the emoji is displaying just fine in this post!

Permissions have been repaired and re-checked, but I can check something specific if that would help.

If I remove "-apple-system" from the CSS font definition the emoji appear (and of course the font changes).

Any ideas?

macOS 10.13, Safari 11.0 (13604.1.38.1.6)

enter image description here

  • For what it's worth, I'm using Safari on MacOS, and I can see the emoji in this question. – Mike Scott Oct 30 '17 at 11:15
3

The problem is that auto activation of fonts had been disabled. FontExplorer X Pro was the culprit.

Safari seems to need auto activation to be able to display emoji correctly.

The solution is to manually re-enable auto activation. In Terminal:

atsutil autoactivation -e

Credit: https://discussions.apple.com/message/32553150#message32553150

  • I'm getting "Note: auto activation is no longer supported." – Gezim Jan 19 at 3:59
  • 1
    @Gezim that's interesting - are you on Mojave? On High Sierra 10.13.6 I get "auto activation globally changed to AutoActivationEnabled" which seems to indicate that the problem was fixed at some point in 2018? The WebKit bug is at: bugs.webkit.org/show_bug.cgi?id=179007 and was last touched Nov 2018. – Matt Sephton Jan 19 at 23:30
  • 1
    I am on Mojave. I'm experiencing this weird issue: apple.stackexchange.com/questions/349042/… – Gezim Jan 19 at 23:47
1

Without knowing your browser version / MacOS version combo, the culprits are probably font corruption or more likely the character encoding isn't UTF-8.

I'm unable to reproduce your screenshot with Safari 11 and 10.12.6, but I can get that specific emoji to falter by switching to other character encodings.

You can check this in Safari in "View" > "Text Encoding".

If you are the developer behind the website in question, you should add the correct character encoding to the page itself to ensure the emoji renders correctly for others. There are good examples of how to do this at W3schools, but this might work too:

<meta charset="UTF-8">

The charset tag in the page is lowercase ;)

You might also try removing the HTML4 charset tag that is also present:

<meta http-equiv="content-type" content="text/html;charset=UTF-8">

Only one is required and the browser should ignore the one that is not right, but that doesn't always happen.

  • Thanks, just posted my software setup. I'm not related to the site but it was the first one I noticed the problem on and it's a nice reduced test. Fixing/removing the charset meta tags has no effect. Any ideas about the -apple-system aspect? No font corruption found using FontDoctor and Font Book. – Matt Sephton Oct 30 '17 at 11:43
  • I can't reproduce your problem. How many different computers / devices have you tried. It could be a cache problem ... have you tried the usual closing and restarting of the browser or the 1998 solution: rebooting the affected machine? – calebx Oct 30 '17 at 12:18
  • I've tried 3 computers, this only happens on my Mac with my user account on it, even after restarts or relaunching the browser. Safari or Safari Tech Preview are affected on my account. On a guest account, the emoji displays just fine. On my other Mac it displays, on my wife's computer it displays. So there's something about my user area that is affecting Safari/fonts. – Matt Sephton Oct 31 '17 at 20:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .