2

I have a 2013 Macbook Air that suddenly won't boot.

It was working as of yesterday. I woke up this morning and it wouldn't start. At the time, the Magsafe2 Adapter was not lit up.

My wife has a similar laptop, so I was able to test my adapter on her Mac and her adapter on my Mac. There doesn't seem to be a problem with the adapter itself based on that.

After moving where the adapter is plugged in, I am getting a green light from the Magsafe2 in my MBA, but it doesn't appear to be charging. I tried:

  1. pressing various keys and moving mouse.
  2. power button
  3. doing an SMC reset (doesn't respond in any visible way to ShiftControlOptionPower)
  4. Leaving it plugged in for a while, etc.

Any suggestions?

There's no fan noise and no probable cause for damage.


To add a further detail, I can get either

  1. Green light if I switch cables with different mac in a short amount of time.
  2. Green light if I remove and then reattach the cable in short amounts of time ( approximately 2 minutes or so)
  3. No light if I leave it unplugged for a bit and mess around with trying to turn it on unplugged for a while

(I don't know if any of this is relevant or should be considered relevant)

3

The problem is unrelated to the status of your MagSafe light. Green means "charged" and amber means "charging." Seeing a green light on your MagSafe means it's getting the signal that they battery is fully charged; there's no other diagnostic info related to this light.

The problem you are having is that your Mac won't turn on. This could be due to:

  • an issue with the power button on the top case assembly - the only way to diagnose this is for the battery to run down completely and then connect to power with auto power on enabled and/or open the case and begin repair level triage / fault isolation / part replacement or repair ( hereafter called open and repair)
  • an issue with the SMC - the only way to diagnose this is to try one time to reset the SMC - if after one reset, it doesn’t power on, open and repair.
  • an issue with the logic board - open and repair
  • an issue with a failed battery dragging the power too low to start - open and repair

If you have some technical skills, you can DIY diagnose the first two by bypassing the button and shorting the power pads on the logic board to simulate a button press or disconnect the battery for 30 seconds to reset the SMC. This will triage and isolate the failure to the connectors running the keyboard and assure the logic board and storage and OS are all functional.

However, the key to this that points in the direction of a logic board failure is this statement:

There's no fan noise...

Regardless of any other issues, if the logic board is functioning properly, the fan will spin at 2000 RPM on MacBook Pro and MacBook Air.

If you're not technically inclined, or it's the third option (likely), it's time to take it in for service to someone that has the tools and training to perform the open and repair steps.

1

You could try to reset the SMC by holding the left-side Shift-Control-Option keys with the power button at the same time with your charger plugged in. I would suggest you to give to a Authorized Apple Repair Shop to check out the problem. But here are some people who had the exact problem:

A link which might help you:

https://support.apple.com/en-in/HT203207

I got some life out of the macbook now and here is some trouble shooting I did to get it to now power on: I did try resetting the SMC but didn't do any good, still didn't power on, so I decided to remove the logic board and left I/O board and look for any components with physical damage and test any fuses soldered to the left I/O, but didn't see any anything, I then test the voltages from the power cable coming from the Left I/O board to the logic board, even when the magsafe plug had the green LED I was getting .5 volts when testing all 3 gray wires being (+) and all 3 black wires being (-) on the power cable at the logic board end which didn't seem right. So, from that I looked over the I/O board and took the black like tape cover off the bottom of the I/O board and found what looks like one of chip capacitor next one of the IC's that looked burned and so I took a cap off a modem PCI card that no longer works and soldered that in replace of the burned one, and then test the voltage output from the power cable that goes to the logic board and now its outputting 12.6 volts, I went a head and put everything back together, now the green light turns orange and the battery is charging but it still doesn't turn on, waited 5 minutes and then it would turn on! Seems to work with the battery having some charge to it, and some reason I have to hold the power button 10 seconds with the macbook unplug with no battery and then continue to hold it for another 10 seconds when plugging in the ac adapter and then I can press the power button and it turns on, this is only if I don't have the battery in, not sure if that is normal and it does seem to run hot too.

  • I appreciate the attempt, but (1) while the linked page describes the category of problems, I'm not sure if it delineates MagSafe is green but won't boot from a plethora of other things (2) where is the lengthy quote from (it doesn't show up that page for me), and (3) already trying to do the SMC reset but don't think it is even happening... – virmaior Oct 29 '17 at 11:11
1

I had the same issue on my 2009 Macbook Pro. I was seemingly not getting any power. When I press the power button and hold for 6 seconds or 10 seconds I would see the green lights on the side.

However when I pressed Command + Shift + Option + the Power button, it booted right up. Only took a couple of seconds to start booting.

I've been getting the service battery warning for a couple of years, so I know I will need to replace the battery if I plan to keep using this one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .