0

Possibly after upgraded to High Sierra, I found that whenever I send a keyboard shortcut (e.g. ⌘+W to close the current tab in Safari), the shortcut is triggered for many times automatically and for example, suddenly 3 of my tabs got closed even though I intended to close only one.

This phenomenon happens inconsistently (sometimes it happens, sometimes it doesn't).

Is this a bug? I'm not sure what has happend in my case and maybe I'm missing something after upgraded to High Sierra...?

Also, is there any way to fix it, for example resetting the keyboard setting or something like that?


UPDATE

I found that this happens in other keys (not even keys combination on shortcut). The below is a screenshot when I tried to type in ghost run -D, where t was triggered for so many times.

enter image description here

UPDATE 2

This happens not only on keyboard shortcuts but also on the normal typing. And I found that people using Karabiner-Elements (which I used as well) report the same issue, though they are not sure yet if it is caused by the software.

  • Just curious, what happens when you try Command + F4 instead? – Monomeeth Oct 27 '17 at 6:12
  • @Monomeeth I remapped Fn to capslock so it should not be working, but what is the reason it is related here? – Blaszard Oct 27 '17 at 15:46
  • @Monomeeth I'm not sure how I can trigger F4 but just tried to disable the remapping temporarily, and put Command, Fn, and F4 simultaneously, but only found out that nothing happened. – Blaszard Oct 27 '17 at 15:49
  • The reason I asked is that Command + F4 is also a keyboard shortcut for closing tabs in Safari - so I was trying to confirm whether it's just a problem with Command + W for some reason, or if it's some sort of deeper problem? – Monomeeth Oct 27 '17 at 19:50
  • @Monomeeth I just found that this is not the problem that happes on the shortcut. I updated. – Blaszard Oct 28 '17 at 0:07
1

There's two things I would try initially: testing your Mac in Safe Mode and, if that doesn't resolve things, resetting the NVRAM.

Test your Mac in Safe Mode

Follow these steps:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. test your keyboard entry as per your question)
  6. Exit Safe Mode by restarting your Mac as normal
  7. Test again to see if the problem still persists

If the problem still persists after following the above steps, you can also try resetting the NVRAM.

Resetting the NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). Since you haven't specified the exact model of Mac you have, follow these generic steps to reset the NVRAM:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then immediately press the commandoptionpr keys.
  3. Keep these keys pressed down for at least 20 seconds!
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Let me know how you go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .