7

Running macOS 10.12.6. I'd like to keep this machine connected to iCloud calendars but prevent it from having a copy of my keychain.

enter image description here

Update: Someone suggested I go into iCloud > account details and turn off allow approving with security code but these are the only tabs that I see. Within the devices tab, I can only remove devices from my account. There is no other option.

enter image description here

  • Hm. Do you log in to your user account with your Apple ID? (Not entirely sure that would cause this--I don't use it myself--but it seems like it might.) – SilverWolf Oct 26 '17 at 18:44
  • Nope local system account is not tied to iCloud in that way. – Michael Wu Oct 26 '17 at 18:45
  • Go to Systempreferences -> iCloud -> Accountdetails. Deselect Allow approving using security code. Turn iCloud keychain off. – dante12 Oct 31 '17 at 22:02
  • I don't see this option at all. I've updated the question to show what I do see when I open account details. Security tab only has a section that says TFA is on and an option to change my password. – Michael Wu Oct 31 '17 at 22:06
  • I think Security Code was the old security method before iOS 11 and macOS High Sierra. Do you happen to have an iOS 11 device that updated security settings? I wonder if you need to update to High Sierra to get them on the same footing. – Brandon Rader Nov 1 '17 at 17:16
-1

If Calendars is the only thing that this Mac needs from your AppleID, why not give it a separate one, and share the Calendar?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .