0

I have an iPhone 8 that was set up from an iPhone 7 backup.

Every few minutes I get a popup asking for an App Store password, except the account it's specifying is an account that belongs to a family member.

Similar questions say that this can happen when an app was installed using a different App Store ID. So to fix this, I uninstalled every installed app.

I'm still getting the popup. Is there any way to fix this?

3
  • So to make sure, the only apps installed are stock iOS apps? (And if that's the case, why not erase it completely and start anew, not from a backup?)
    – Tuesday
    Commented Oct 26, 2017 at 4:03
  • Have you tried having them sign in to your phone?
    – Allison
    Commented Oct 29, 2017 at 2:57
  • @Sirens I would, they're not available to do so
    – user81357
    Commented Oct 29, 2017 at 3:20

1 Answer 1

1

Head into Settings > iTunes & App Stores and at the top you should see that your iPhone is logged in with your family member's Apple ID.

Click on the Apple ID, then tap on Sign Out and then login with your Apple ID.

6
  • My Apple ID is already there.
    – user81357
    Commented Oct 25, 2017 at 20:35
  • What exactly does the pop-up say? Commented Oct 25, 2017 at 20:40
  • Sign In To iTunes Store - Enter the password for your Apple ID - [email protected] - Password:
    – user81357
    Commented Oct 25, 2017 at 20:41
  • Ok this should fix the problem, open the App Store, tap on the profile icon from the top right corner and then tap on Sign Out Commented Oct 25, 2017 at 20:44
  • Tried that too, no dice.
    – user81357
    Commented Oct 25, 2017 at 20:55

You must log in to answer this question.