3

I have a removable hard drive in NTFS format that is connected to macbook pro through usb.

For some reason finder doesn't show one of the directories. First I thought that I removed it by mistake, but when I opened it on Ubuntu the directory was there.

The directory is not hidden, its name written in Cyrillic without spaces. It holds some documents. There are other directories similar to this one (with Cyrillic names and files inside) but they appear in finder.

I also tried to verify it through terminal - ls command doesn't list this folder (however ls lists it on Ubuntu).

Q: Does anybody know what could be the reason for such a wired behaviour and how to solve this issue?

I have OS Hight Sierra with latest updates.

UPDATE: Here is the ls -alh output from Ubuntu:

$ ls -alh
drwxrwxrwx 1 oleksandr oleksandr 8,0K вер  2 18:47 Папка

Note: I removed the other folders from the output, but they have the same permissions. The name of the folder is also changed. "вер" states for September in Ukrainian.

Here is locale output from my macbook:

LANG=
LC_COLLATE="C"
LC_CTYPE="UTF-8"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL=
  • could you add the results of ls -alh from ubuntu? – Mr. Kennedy Oct 25 '17 at 20:41
  • @Mr.Kennedy I updated the question with the output. – Oleksandr Shpota Oct 25 '17 at 21:06
  • I think it has to do with your locale setting. Type locale at the command prompt and post the output. – Allan Oct 26 '17 at 0:20
  • @Allan I added locale output. – Oleksandr Shpota Oct 26 '17 at 6:43
  • 1
    My guess is that you've found a bug in Apple's NTFS drivers. I'd try to see if you can reproduce it with a disk image or something, and send a Radar report. – Charles Srstka Oct 28 '17 at 2:03

You must log in to answer this question.

Browse other questions tagged .