7

I've had this phone for 5 years. In that time, I have occasionally added non-words to the dictionary by mistake, for example by tapping the wrong place on the screen. I want to browse my user dictionary and arbitrarily remove entries I dislike.

As an example: at some point, I fat-fingered my phone into thinking that do n is a correct spelling of don't. I think that means I need to remove "n" as a word, but many attempts with solutions like this one seem to fail in this specific scenario.

Requirements:

  1. Erasing the entire user dictionary is not acceptable.

  2. Disabling autocorrect/predictive text (or whatever it's called) is not acceptable.

  3. I am attempting to remove,not add words. Your answer must be specifically for removing words.

  4. The ideal solution will allow me to browse my user dictionary and remove one or more entries. If that is not possible, a solution that allows me to spot-remove suggestions in situ is fine.

  5. If you suggest a third-party app, it must be available to the public at the time of posting, and any changes it makes must apply to the entire OS -- if it only cleans up e.g. the Messages dictionary, it will be rejected. I care about a whole OS solution.

  6. No solution that requires jailbreaking, voiding the warranty, or doing anything illegal/dangerous will be accepted.

  7. If the fact is it's not currently possible, I will only choose an answer to that effect if it cites authoritative sources.

Everything I've been able to find on the internet on this topic did not help. Your help is very much appreciated.

4
  • 1
    I am not gonna take time to work it out but most likely the only way to do this would be to backup your phone, use a backup browser to browse files, find the dictionary file, remove the word, and then restore from backup.
    – JBis
    Aug 27, 2018 at 2:38
  • Fantastic. I currently have 20 autocorrecting to 2.0 every time I type it. How is that even possible. Aug 13, 2021 at 17:48
  • And if anyone at Apple ever comes across this can we please remove contacts as a source of auto correct. I don't need 'John STARBUCKS' being suggested every time I type John. Aug 13, 2021 at 17:49
  • I had the 2.0 problem. I just added “20” as a text replacement for “20” in the keyboard settings and seems to have fixed it
    – sam
    Oct 18, 2021 at 7:01

6 Answers 6

2

Go to General then Keyboard then go to Text Replacement and delete which ever you want gone :)

1

If you open Settings, go to the General tab, scroll down to Reset and click on Reset Keyboard Dictionary it will reset it to the standard dictionary/s that you have selected. Unfortunately there is no way to go through and remove individual words, but hopefully this helps you.

2
  • 1
    Thanks for the tip! However, this answer violates requirement #1: "erasing the entire dictionary is not acceptable," and it also violates requirement #7 by not citing an authoritative source to the effect that "there is no way to go through and remove individual words."
    – Tom
    Mar 27, 2018 at 14:53
  • 1
    @Tom ok soz. I'll see if there are other ways
    – Srevilo
    Mar 27, 2018 at 20:23
1

This solution taken from a response on URL:

How can I get the iPhone to "forget" certain words?

Worked for me. It did not take nine times for it to figure it out, you experience may vary.

Good luck, Barry

"I opened notes, typed the word I wanted and when the incorrect autocorrect showed I pressed the cross. I pressed space bar and repeated the process 8 times. On the 9th time the incorrect suggestion stopped showing. Now it doesn't suggest the incorrect word anywhere!" --answered Feb 3 '13 at 5:36 Glenbod

1
  • Unfortunately in modern designs it seems this feature is missing. Some other sources mention they changed it to tap-and-hold but it doesn’t work either. I’m unable to remove a word from dictionary :( May 8, 2021 at 21:29
1

I may be a year to late but my phone had “I said” auto correcting to “I. Sa’id” so I went into my text replacement and put I short cut for “isa to mean I said” now my phone only types I said no matter how I type it in weather I type the shortcut or the words out. the “I. Sa’id” auto correct is completely gone!

1
  • Welcome to Ask Different :) This place is reserved for posting the answer to the original question. If you have one, please consider editing your post and share it. If you have a separate question, ask it here. Else, consider deleting this post.
    – Nimesh Neema
    Mar 30, 2019 at 5:50
0

I found the solution that works, I read it on one of the forums and it worked. I added a "Text Replacement" under Keyboards in Settings. For me "and" was always auto correcting to "abs", I tried all solutions mentioned, the only one that worked was adding to "Text Replacement" "and" / "and" for Phrase / Shortcuts. This forced my phone to stop replacing and with abs.

0

I think the auto correct of 20 for 2.0 must be a system glitch. I have it also and it only started recently after iOS updates.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .