2

I'd like OS X to stop switching Desktops when an app gains focus. The traditional solutions to this do not work in Sierra. There is now a new behavior: if an app is brought to the foreground twice in a row (i.e. click on the app icon in the Dock twice), then the Space automagically switches.

I have not seen this new behavior until upgrading to Sierra, and have not yet seen any solution how disable it.

Deselecting When switching to an application, switch to a Space with open windows for the application, nor defaults write com.apple.Dock workspaces-auto-swoosh -bool NO stop this behavior.

Is there some way to stop Spaces from switching spaces when the active app is activated a second time?

  • In my experience, this has been happening since MC became a thing and I hate it too. I have auto-switching disabled, but it still happens if I inadvertently click a dock icon of an app without a window on the current desktop that's already in the foreground. IMO, if there's no window in the foreground on the current desktop, it should create one instead of jump to another desktop (which I use for work on different projects). What's worse is that when you click to reveal a download in Safari and a folder is open on a different desktop, it doesn't switch desktops nor does it open a new window – hepcat72 Aug 15 '18 at 11:46

You must log in to answer this question.

Browse other questions tagged .