2

If you press Cmd+Enter on iTerm while having the preference "Use native fullscreen windows" turned off, it goes into fullscreen but not the standard MacOS-way.

Is there a way of doing the same in Terminal.app? I know I can use Ctrl+Cmd+F to enter a native full screen. And I know I can maximize the window manually to eventually consume all of the screen, but in this case the title is still visible.

  • 2
    Just out of curiosity, why don't you want to use the native method of going into fullscreen? – Kyle Oct 22 '17 at 17:46
  • @Kyle The reason was that I thought I couldn't use 2 screens if the one was occupied by a native fullscreen app. But I just learned about the "Displays have separate Spaces" options so. Oh I also dislike the animation effects. – Agis Oct 22 '17 at 20:46
  • @Kyle Another reason for this that bugs me a lot: You can't cycle through windows that are natively fullscreen. – Agis Oct 23 '17 at 8:12
0

No, there's no support for this in Terminal.app.

-1

Option 1

There is an incredibly simply answer to your problem:

Double-click the title bar of the window.

Double-clicking the window again will return it to the previous size and position.

Note: Make sure that "Double-click a window's title bar to zoom" is set under System Preferences -> Dock.

enter image description here

Option 2

Add a system-wide keyboard shortcut. for the Zoom action.

  • 1
    They don't want the title of the window to be visible. – Kyle Oct 22 '17 at 17:45
  • As @Kyle said, this isn't what I'm searching for since the title bar will still be visible. – Agis Oct 22 '17 at 18:30
  • Ahh. Missed the "title is still visible" bit. That's a case for native fullscreen then. – ephsmith Oct 22 '17 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .