1

I'm from Switzerland with a FTTH connection. The ISP gave me an Icotera IGW3000 router. The problem is: all my Macs and iOS devices lose internet connection every x minutes.

On my Macs, I have to run Network Diagnostics:

  • iMac 27'' 2013
  • MacBook Pro 2016

On my iOS devices, I have to turn off/on wifi:

  • iPhone 6s
  • iPad Air 2

On macOS, I see first Dropbox going offline. In my system log I see these lines:

Oct 22 12:06:48 Micheles-iMac com.apple.xpc.launchd[1] (com.apple.quicklook[1464]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.quicklook

Oct 22 11:58:51 Micheles-iMac com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit

Oct 22 11:48:11 Micheles-iMac com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.user.501): Service "com.apple.NetworkDiagnostics.7436" tried to hijack endpoint "com.apple.NetworkDiagnostic.agent" from owner: com.apple.NetworkDiagnostics
  • Welcome to Ask Different! :) Something not clear from your question is whether or not other devices are connecting fine and staying connected? For example, do you have any Windows computers, Android phones/tablets, or other internet connected devices that stay connected while your Macs, iPhones and iPads don't? This is important because, at first glance, your internet connection/modem/router seem to be the common factor here. – Monomeeth Oct 22 '17 at 10:25
  • Ho, thank you for your kind reply. All my devices lose internet connection. Sadly, I have no Android nor Windows machines to test. – Michele Bugliaro Goggia Oct 22 '17 at 11:44
1

Note: This answer can be applied to any ISP supplied router; it's not limited to the model identified in the question.

The fact that all your devices are losing Internet at the same time narrows the potential failures down significantly and rules out a problem with your Macs and iOS devices.

The issue is down to the "router" that your provider issued you and there are two potential issues:

  • The WiFi radio could be faulty
  • The router is faulty

To test out which is the issue, connect your iMac or MacBook Pro directly to the router via Ethernet cable into one of the LAN ports (see below). Make sure you turn off your wireless on that device.

enter image description here

If the problem remains, it's with the router's connection to your service provider.

If the problem goes away on the Ethernet connected device, the WiFi radio is at fault and the router needs to be replaced. However, I personally, wouldn't depend on a service provider supplied router. I would get one that I have control over and just put their router in "bridge mode."

  • Using OpenDNS sure made things faster. The issue is still present but not as frequent. I have tested Ethernet and this always works. – Michele Bugliaro Goggia Oct 23 '17 at 4:16
  • So, the problem still exists? Did you try the Ethernet connection? – Allan Oct 23 '17 at 11:33
  • Solved by changing a value in the router config + OpenDNS. – Michele Bugliaro Goggia Nov 24 '17 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .