1

I have an A1260, MacBook Pro. I removed the screen due to it being cracked and ended up using it as a server and just connect it up to a display via DVI whenever I need to (most of the time I used screen sharing). Anyways:

It won't start up. When I press the power button, it turns on, the DVD drive spins up, and the front LED goes from bright to dim. There is no startup chime. Resetting the SMC and PRAM doesn't do anything and don't actually work as expected. Meaning when resetting the PRAM the device doesn't reboot and no start up chime is heard.

I decided to take the device back apart and see if I notice any faulty components or any weird shortages from when I disconnected the display and took it off the device. I didn't notice anything out of the ordinary (though I'm an amateur). What I did notice, however, is if I turned the machine on, and raised and lowered the keyboard, the status LED on the front would dim when the keyboard was down and would brighten when the keyboard was up. A quick google search didn't turn up anything at all.

I also noticed that if I turn on the machine and keep holding the power button, after a short period of time the status LED would blink rapidly and then the machine would reboot.

Any ideas what kind of issue this is?

Thanks!

-- edit --

I forgot to mention, if I connect the device up to a monitor, I get an "invalid signal" status displayed on the monitor. Sometimes no signal is detected at all.

  • If you don't hear the startup chime or any other beeps/tones, your logic board is probably shot. The one thing you can try is to test the memory modules by removing one and attempting to boot. Keep swapping modules/slots until you have tried all combinations. If it doesn't boot after that, it's time to upgrade or get it repaired. – Allan Oct 22 '17 at 1:43
  • @Allan If I remove all RAM modules, I do get a few beeps from the speakers notifying me of the lack of RAM. Still think it's a shot board? I was able to get it to boot once randomly, but had to restart due to a software update and it never came back from it -.- – Kyle Oct 22 '17 at 2:24
  • Did you start testing the modules as described? – Allan Oct 22 '17 at 10:18
  • @Allan yes, that was actually one of the first things I tried, sorry I didn’t mention that. It had no difference. – Kyle Oct 22 '17 at 15:30

You must log in to answer this question.

Browse other questions tagged .