After upgrading to High Sierra, I'm getting this error message about 30-50 times a day:

enter image description here

Is there any way to find out what is causing this error? Any ideas how to fix it?

5 Answers 5


So none of the given answers works on High Sierra (OS X 10.16.x) and I don't have Clean My Mac 3. This Apple article did the trick for me and pretty easily: https://support.apple.com/en-us/HT203538.

This involves setting the permissions through the finder and then resetting the permissions by using the command

diskutil resetUserPermissions / `id -u`

Make sure you cd to the appropriate home folder (I did this logged in as myself for another user that was experiencing the issue) to avoid access errors.

  • 1
    Thanks, this worked for me, just a little information: id -u gives currently logged in user's id.
    – ganjim
    May 31, 2019 at 13:49
  • FYI This worked on Mojave as well. We had started getting "MacOS needs to repair your Library to run applications" error messages. Files disappeared from the desktop, and many applications has a slash through them (no permission to run.) Disk Utilities didn't fix it, and neither did running repairHomePermissions in Recovery Mode. Nor did reinstalling Mojave. These are all things worth trying in general, but diskutil resetUserPermissions \ <uid> is what fixed it for us.
    – Bampfer
    Feb 17, 2021 at 19:47

This fixed my problem.

To set the permissions on your user folder as giving you access/ownership:

sudo chown -R <user> ~/Library
sudo chgrp -R <groupname> ~/Library

You get the your username by running:

id -u

You get your group by running:

id -g 
  • Welcome to Ask Different. With the goal of writing a clear and concise answer, please take a look at a few things: 1) How is your problem related to the OP's? 2) How does one determine their username and groupname? 3) How does this address the OP's question?
    – Allan
    Apr 26, 2018 at 23:16


  • Open disc Utility and select you Systemdrive, run First Aid.
  • Restart

If this step doesn't work, try the second


  • Restart, press CMD + R to boot into recovery
  • Next, choose Terminal from the Utilities menu
  • Type resetpassword
  • Select your Systemdrive (e.g. Macintosh HD/SSD)
  • Select your Username from the list
  • Click on Reset Home folder Permissions and ACL's button
  • Reboot and logged in your Account and see that your problem is repaired.
  • Sometimes you need to run reset permissions a second time until it works.

You don't need both steps, if one works, you're done.

  • This seems outdated; on the new version of the OS, it doesn't have any such option.
    – SilverWolf
    Oct 24, 2018 at 7:10

It appears that the problem lies with Permissions, yet High Sierra (10.13.3) has removed access to 'Repair Permissions' in Disk Utility.

A neat way round this is to use CleanMyMac3. In addition to its basic role of cleaning unwanted files from your Mac, it has an option of Maintenance which offers 'Repair Permissions'. This took just a few seconds on my 13" MBP and the problem is solved – no hassle, no use of Terminal. I'm mighty impressed with this program.


Faced the same problem for many days. After upgrading to Mojave. Disk utility repair was only a temporary fix.
Then finally found this link. It did the trick. https://support.apple.com/en-us/HT203538 Essentially, resetting user permissions.

  • Welcome to AskDifferent. While multiple (and also similar) answers are totally fine please try to provide additional value if you basically post a link which has already been mentioned in another answer.
    – nohillside
    Dec 23, 2018 at 19:53
  • Also...Apple links are notorious for going stale making the link-only answer useless in the future. It's best to put the key points here and supply the link for reference.
    – Allan
    Dec 23, 2018 at 23:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .