1

In an attempt to restore my iPhone 6 Plus, and update it to the latest iOS version, my iPhone 6 Plus keeps on restarting during the Restore. It happens during the stage where iTunes displays Extracting software...

After it's very quick reboot (It only flashes the white screen, and darkened Apple logo for a split second), it returns to the iTunes logo with and arrow and lightning charger below it. The problem is that iTunes then looses connection with the device and when it comes to actually restoring it - It fails.

It would be fantastic if anyone could help me with this.

As a note, I am using MacOS Sierra on a MacBook Pro (13 inch, Mid-2010) and iTunes is the latest version currently available to my device.

  • Have you tried DFU mode? – Sirens Oct 21 '17 at 19:49
  • @Sirens Yeah. It still didn't work – Hazim Sager Oct 22 '17 at 13:58
  • Have you tried another computer? – Sirens Oct 22 '17 at 19:16
1

Please try by another USB connector.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .