1

input methods

I am running 10.11.5, after shutting my MacBook pro to trigger sleep, and then reopening it, the input method will always switch back to Australian, I want to keep it set to Squirrel (http://rime.im/ -- N.B. all the documentation for this is in Chinese). How do I make it so that squirrel is always selected? Ideally, I could even remove Australian, but for some reason, I am prevented from removing all the inbuilt English input methods.

stupid restriction

1

I don't use Squirrel, so this answer may not necessarily apply.

Once you've added Squirrel as an Input Source in your Keyboard System Preferences (as you've already done), you should be able to make this the default in your Language and Region System Preferences.

More specifically:

  1. Go to Apple > System Preferences
  2. Select Language & Region
  3. Click + button at bottom left
  4. Choose the appropriate language
  5. When prompted set this to be your primary language
  6. You may still be prompted to add an input source in your Keyboard preferences, if so just redo that as well (i.e. add Squirrel)
  7. You may also need to restart your Mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .