0

I have El Capital 10.11.6 and I do not wish to upgrade, however I need to clarify whether this means I cannot download and experiment with ARKit?

The latest Xcode version that is compatible with El Capitan is 8.2.1 but when trying to download ARKit, it suggests using Xcode 9.x so I wonder if this is just a suggestion or absolute requirement?

In other words, the fact that I would like to remain in El Capitan and Xcode 8.2.1 definitely means that I can never download and use ARKit. Correct?

3

In order to develop ARKit apps you need to use Xcode 9.x. Xcide 8.2.x does not include ARKit.

From Apple's Developer page:

Get Started with ARKit

Xcode 9 and iOS 11 Download iOS 11 and the latest version of Xcode 9, which includes the iOS 11 SDK to build AR features in your app today.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .