0

For over a year, I've been using rsync to add a layer of archiving to my systems. It has worked fine.

I recently upgraded the computers to High Sierra. My server contains a volume incorporating a sparsebundle. In the past, this volume (/Volume/Videos) archived without problems. Once I ran my script on High Sierra, it fails with:

 rsync: unpack_smb_acl: sys_acl_get_info(): No such file or directory (2)
 rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1178) [sender=3.1.2]

I've been using rsync 3.1.2 with the -aAXE options to get the ACLs,etc. For this single volume, I'm now trying the default rsync without those options, and it appears to be working. Later, I'll try again with rsync 3.1.2 and no AXE options.

Has anyone else seen this behavior in High Sierra? Does anyone have an explanation about why it is happening?

1

Driving today, I realized I had not reset the ACL for that folder; part of my upgrade maintenance ended up involving some group assignment repairs, and I had not changed that group, nor promulgated the new group, so an unassigned unique identifier was listed as the ACL. Rsync does not like this.

Once I assigned workgroup back to this folder, and promulgated the ACL, rsync 3.1.2 handled the job correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .